summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-25 13:31:35 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-25 14:03:15 +0100
commit210a4c45fed4a67c348670e604d19d465f19de18 (patch)
tree01d8067c24c114376f3b0b3c972dbd022ca60c11
parentsys-kernel/gentoo-sources: Linux patch 5.15.5 (diff)
downloadgentoo-210a4c45.tar.gz
gentoo-210a4c45.tar.bz2
gentoo-210a4c45.zip
dev-ruby/dependor: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/dependor/dependor-1.0.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/dependor/dependor-1.0.1-r1.ebuild b/dev-ruby/dependor/dependor-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..24455dba0a49
--- /dev/null
+++ b/dev-ruby/dependor/dependor-1.0.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reduces duplication when doing manual dependency injection"
+HOMEPAGE="https://github.com/psyho/dependor"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e '/simplecov/,/^end/ s:^:#:' \
+ -e '/color_enabled/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+}