summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-02-01 14:25:08 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-02-01 15:09:56 +0100
commit212262379279d51230af10047e97114451266443 (patch)
treebf6f7473174afcda571dced9a85881cf78919094
parentdev-python/hcloud-python: remove old (diff)
downloadgentoo-21226237.tar.gz
gentoo-21226237.tar.bz2
gentoo-21226237.zip
x11-themes/fluent-icon-theme: bump to 2023.02.01
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--x11-themes/fluent-icon-theme/Manifest1
-rw-r--r--x11-themes/fluent-icon-theme/fluent-icon-theme-2023.02.01.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-themes/fluent-icon-theme/Manifest b/x11-themes/fluent-icon-theme/Manifest
index df9e2dcea56f..daaa9f9abfd4 100644
--- a/x11-themes/fluent-icon-theme/Manifest
+++ b/x11-themes/fluent-icon-theme/Manifest
@@ -1,3 +1,4 @@
DIST fluent-icon-theme-2022.09.20.tar.gz 5735903 BLAKE2B b2804099a5d362681fe53db3d496b8beb202ad2a4844e55724773f7b2d2aacf2948247867d4a06b128c2a56d86a231429d6efa5f47e90820203264e7edda2677 SHA512 46468b60778665dd24132776aed43d30385933cd8253cc5687ce89f5e9c933a64bf7823ee221f65248e39bc1e3e7ea0f76401e4908ddba54235d48113851d3b4
DIST fluent-icon-theme-2022.11.05.tar.gz 5817988 BLAKE2B 821b2d048ab818ff65b6295267023012143d46f087f14ff7ee34a5f2769847919c41dfe15b596ce4cd5f69475eb77686344b6742f7c70e6605ebc3ae80250e47 SHA512 52757ed27bae8bfb3199b005cfd524c2c1d604daa94af3ccfa9c31dbb9ea278edcd6b6aa7126df63284b1bd05058a6398a4cf7a7a42eedfd41cc4bb0dd600ca0
DIST fluent-icon-theme-2022.11.30.tar.gz 5822571 BLAKE2B 876ef9350b10b868017195929f9b7503033785abfee020b6a0e3fe1820e481f52cebe3836ebfef2c075d65160425d804903b0f7e1e067b86d9cee559b23ceecd SHA512 20939ad5fd393971477cc66dcf1e5dd8e38ec6653daed206c003348daedc62e7bc485488327611f00fe26420b3bb4a8476035495f738af1f7fa407dd47e9efd1
+DIST fluent-icon-theme-2023.02.01.tar.gz 5910433 BLAKE2B 8725381ffdf184e21fb44343a64cfc1ebb91b32abe9bf72a5abec16a49139ffbb5b9217232e068338ab311b6840064e8b99f912d1d886938ee0289d612d20640 SHA512 d6b5ef6b17e8207cefcab8d83f8a3cacff49d388fae5b5c6807f61c820d27a1c9cc96289a61cafdb2707fa912eaf50048264b653e191e26e33844b8dd1091013
diff --git a/x11-themes/fluent-icon-theme/fluent-icon-theme-2023.02.01.ebuild b/x11-themes/fluent-icon-theme/fluent-icon-theme-2023.02.01.ebuild
new file mode 100644
index 000000000000..82a474b46799
--- /dev/null
+++ b/x11-themes/fluent-icon-theme/fluent-icon-theme-2023.02.01.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ie. 2021.12.20 -> 2021-12-20
+MY_PV="${PV//./-}"
+MY_PN="${PN^}"
+
+inherit xdg
+
+DESCRIPTION="Fluent icon theme for Linux desktops"
+HOMEPAGE="https://github.com/vinceliuice/Fluent-icon-theme"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vinceliuice/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/vinceliuice/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+black +hardlink round"
+RESTRICT="binchecks strip test"
+
+BDEPEND="sys-apps/util-linux[hardlink(-)?]"
+
+src_prepare() {
+ default
+
+ sed -i '/gtk-update-icon-cache/d' install.sh || die
+}
+
+src_install() {
+ dodir /usr/share/icons
+ local myinstallopts=(
+ --all
+ --dest "${ED}/usr/share/icons"
+ $(usev black '--black')
+ $(usev round '--round')
+ )
+ bash ./install.sh "${myinstallopts[@]}" || die "install script failed"
+
+ if use hardlink; then
+ einfo "Linking duplicate icons... (may take a long time)"
+ hardlink -pot "${ED}/usr/share/icons" || die "hardlink failed"
+ fi
+
+ # installs broken symlink (by design, but we remove it due to QA warnings)
+ find "${ED}" -xtype l -delete || die "removing broken symlinks failed"
+
+ einstalldocs
+}