summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-22 18:12:08 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-22 18:51:13 +0200
commit212ac9aca5c2de1ad9cfe8160a1e98f48422d600 (patch)
tree13bafc1829332a34c459dcf9162f6c0ebc6832c0
parentapp-emulation/docker: rebase patch, get rid of custom src_prepare (diff)
downloadgentoo-212ac9ac.tar.gz
gentoo-212ac9ac.tar.bz2
gentoo-212ac9ac.zip
app-emulation/protontricks: add 1.5.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch36
-rw-r--r--app-emulation/protontricks/protontricks-1.5.0.ebuild57
3 files changed, 94 insertions, 0 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 219f70b98674..8171f3b99e44 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,2 +1,3 @@
DIST protontricks-1.4.3.tar.gz 43573 BLAKE2B 3a3050ba6e940182d81d98498a5558433ceaa4282f5a23fb93b3cfc299699381493eb2912c5f03bb6a8092be5c50b94bf7181208cda3d4c0f4c90c0f438f7f1b SHA512 7ca8c7c273d92f7c4526caaa8c9db6988c642913c33c6b6188d285d5cfbe30924533a9f024135865cdc1a25bd867ac00bd915b0a61417d17fe0e5ee451417e64
DIST protontricks-1.4.4.tar.gz 45204 BLAKE2B 3fc66acae79a39e8dc7a5d507e4abcdad24da13a03e10954b667769a801ac42addb55980e3de413e71ad5395e773b065f8f1dca2e694c835a07b8993b4fb5f0e SHA512 4c61da27e97f1b46150f2808c27d1fcf7394f2cc4f272eada54abc4fdd9229443405f7466d3a1ba5603e3c40a025dbbd8fde512334c6007a64687867625abc4c
+DIST protontricks-1.5.0.tar.gz 46957 BLAKE2B 622affd9a1bfff3a5cd76fa8e279f25b5c91a6f040b6cc4e5f42e58be08a232fad2be179a47e063b45b1b1bb11b6ae9ce26cce499f4c1dae460be0bb8247e619 SHA512 6df3e0dd638684e70a8d40b7440e2340765109e31dd47fa5e33e4959bc34d3ff4cfa70c8689cafdcce82f1d97ba6d25de724ca7439e5d1ffd634b729ab222716
diff --git a/app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch b/app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch
new file mode 100644
index 000000000000..a19d8494657b
--- /dev/null
+++ b/app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch
@@ -0,0 +1,36 @@
+Since version 1.4.1 upstream has used setuptools-scm to determine the
+current version number. Unfortunately the package in question does not
+support GitHub release archives, using GitHub VCS snapshots would require
+retrieving and updating commit hashes corresponding to release tags, and
+PyPI tarballs do not contain tests. setuptools_scm_git_archive does not
+help because it requires extra files to be included in the repository,
+which upstream has not done.
+
+Seeing as we already know the version number, bypass setuptools_scm
+altogether and create the version file ourselves. For obvious reasons the
+latter has to be done in ebuilds themselves.
+
+--- a/setup.py
++++ b/setup.py
+@@ -16,9 +16,6 @@
+
+ setup(
+ name="protontricks",
+- use_scm_version={
+- "write_to": "src/protontricks/_version.py"
+- },
+ description=DESCRIPTION,
+ long_description=LONG_DESCRIPTION,
+ author=AUTHOR,
+@@ -28,11 +25,6 @@
+ packages=["protontricks"],
+ package_data={"": ["LICENSE"]},
+ package_dir={"protontricks": "src/protontricks"},
+- setup_requires=[
+- # setuptools-scm v6 requires Python 3.6+
+- "setuptools_scm<6 ; python_version <= '3.5'",
+- "setuptools_scm ; python_version > '3.5'"
+- ],
+ install_requires=["vdf>=3.2"],
+ entry_points={
+ "console_scripts": [
diff --git a/app-emulation/protontricks/protontricks-1.5.0.ebuild b/app-emulation/protontricks/protontricks-1.5.0.ebuild
new file mode 100644
index 000000000000..2540f44fa284
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.5.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="https://github.com/Matoking/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0_no-setuptools-scm.patch
+)
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
+}
+
+pkg_postinst() {
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}