summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-05-14 10:19:13 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-05-14 10:19:34 -0400
commit214ae6b02cd2074173aca80a344571c52f27b5db (patch)
treef45480f9e1828560869276bb91ae4ee041f2fc59
parentwww-apps/moodle: version bumps to 3.5.18, 3.8.9, 3.9.6, 3.10.3 (diff)
downloadgentoo-214ae6b0.tar.gz
gentoo-214ae6b0.tar.bz2
gentoo-214ae6b0.zip
sci-mathematics/eclib: new upstream version eclib-20210503.
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/eclib/Manifest1
-rw-r--r--sci-mathematics/eclib/eclib-20210503.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index 176b940896e2..50866b965f5a 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1 +1,2 @@
DIST eclib-20190909.tar.bz2 914900 BLAKE2B df57972792f96e65b25db5a2ab1063d5a8f1ad05edbed77d9ca2632ddfb4af2cb8586e572155beec09cc0c03472300d1e6fcbdda3527c36e9106006239f50600 SHA512 df829b10c353f528f2040b55d6198e3a48eba179b9a80e71794e4c6d46ee9bb13b3eccec15c7d286ec5d8252e6ba91157c2a08ac4e2da86969a4158450a41960
+DIST eclib-20210503.tar.bz2 920919 BLAKE2B 5481769d6e9152d85f69a15d856701b5faf0b2d7d8c5fd0e2b6452d7be1f5de23ec2c3f60603d87e4d95f25295ef2a2f44dacf5c844c6970e96a83cd61bdfe66 SHA512 a3ee992d97c00ec5069a090d19914b9e1d00b25f5f1fff1ccd02deb1d240e4773bcfe0e00366808b7afe3a24e0aed8bb2fc4e9cb4f9f97dfc6ef70c43362bd38
diff --git a/sci-mathematics/eclib/eclib-20210503.ebuild b/sci-mathematics/eclib/eclib-20210503.ebuild
new file mode 100644
index 000000000000..30537d59eb49
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20210503.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+# Major version of /usr/lib64/libec.so
+SLOT="0/7"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}