summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-29 03:33:02 +0000
committerSam James <sam@gentoo.org>2023-10-29 03:33:02 +0000
commit214b26e564b13c56363258163cda0c16173b3636 (patch)
tree803ed682b2b7f7fd3f81b7321827a7b3b6ac568c
parentdev-perl/XS-Parse-Sublike: add 0.210.0 (diff)
downloadgentoo-214b26e564b13c56363258163cda0c16173b3636.tar.gz
gentoo-214b26e564b13c56363258163cda0c16173b3636.tar.bz2
gentoo-214b26e564b13c56363258163cda0c16173b3636.zip
dev-python/xarray: skip tests caused by numpy quirk/bug
See bug for details, it looks like it's a numpy quirk/feature/misfeature...? Closes: https://bugs.gentoo.org/916460 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/xarray/xarray-2023.10.1-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/xarray/xarray-2023.10.1-r1.ebuild b/dev-python/xarray/xarray-2023.10.1-r1.ebuild
index 2acfcd5dc6b8..287b9c7cf488 100644
--- a/dev-python/xarray/xarray-2023.10.1-r1.ebuild
+++ b/dev-python/xarray/xarray-2023.10.1-r1.ebuild
@@ -18,6 +18,7 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="big-endian"
RDEPEND="
>=dev-python/numpy-1.22[${PYTHON_USEDEP}]
@@ -58,5 +59,25 @@ EPYTEST_DESELECT=(
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ if ! has_version ">=dev-python/scipy-1.4[${PYTHON_USEDEP}]" ; then
+ EPYTEST_DESELECT+=(
+ 'xarray/tests/test_missing.py::test_interpolate_na_2d[coords1]'
+ )
+ fi
+
+ if use big-endian ; then
+ EPYTEST_DESELECT+=(
+ # Appears to be a numpy issue in display? See bug #916460.
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-20-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-09-21T00:12:44.145224808-ns-float64-1e+30-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225216-ns-float64--9.223372036854776e+18-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225-us-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-01-01T00:00:01.000001-us-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:21:52.901038080-ns-float32-20.0-True]'
+ )
+ fi
+
epytest -p xdist.plugin -n "$(makeopts_jobs)" --dist=worksteal
}