summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-30 22:18:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-30 22:19:24 +0300
commit215b8a0f648f7ac1306cc3001d56e29d6a348d5c (patch)
treedc10e0c20d13ca7bab7e073e06ddafb5dd559935
parentdev-python/pyflakes: add 2.5.0 (diff)
downloadgentoo-215b8a0f.tar.gz
gentoo-215b8a0f.tar.bz2
gentoo-215b8a0f.zip
dev-python/nuitka: add 1.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/nuitka/Manifest1
-rw-r--r--dev-python/nuitka/nuitka-1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
index 85094745f9c3..23d161b9464d 100644
--- a/dev-python/nuitka/Manifest
+++ b/dev-python/nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-0.9.5.tar.gz 3858378 BLAKE2B 0b8aa2b191caaa348fda81af41d7a4ad486479742acb929c6e0f0c1ec08b06ca02c5cae46b986c569a8bb792e15fbb90e49db9ece3b226d4e09c054b4311f079 SHA512 4e0def27cc12f4b37debb509c015ba9e56649e82ecede31c142b7c420424364fb243932bd146397bfb82aea1591a06566b346a1b2c6d64cf26cdc59eb77cf875
DIST Nuitka-0.9.6.tar.gz 3858273 BLAKE2B 5fbe454c5f5612d94342b1247b463a4248a35123d7d4515dadb4c9f4cf5b6714f55e1972d55f60cfdfe65ca97af5fae2cfc92009b274ccf9adaf944217a39333 SHA512 6088459a12f5506a547d40a4c3f0f16f8ab470ee4875d36dfad97e4ba25d7cdc25cae1115a11dd7752dafe51d6c83d80798c74a110c995e47ba127d9b2afbf81
+DIST Nuitka-1.0.tar.gz 3892664 BLAKE2B 6772c4af5a4fcee704a0c9b14b25a5ae8ca0d5663f2a60791dd194ae402dc0dccad1fbc3b85089469090f2f10cb0641fe739ef3f1c8c236292ac7e468c0de27d SHA512 4b8d17e49da152ab7c0ad146296375e8f8566bbd730ceac158c8dc9ed1588509384627f538dec347774b890a4715b4ba054b3be66b1b425bb736d35752b5db58
diff --git a/dev-python/nuitka/nuitka-1.0.ebuild b/dev-python/nuitka/nuitka-1.0.ebuild
new file mode 100644
index 000000000000..5b987e13729d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}