summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-08 06:29:30 +0100
committerSam James <sam@gentoo.org>2023-08-08 06:29:30 +0100
commit2161ffcf29003bea270f6f077c6e4a7c14cc19b8 (patch)
tree08be5f0bd7aa8784b7be4d51c826e5a565ac373c
parentapp-shells/squirrelsh: Fix C++17 does not allow register storage class (diff)
downloadgentoo-2161ffcf29003bea270f6f077c6e4a7c14cc19b8.tar.gz
gentoo-2161ffcf29003bea270f6f077c6e4a7c14cc19b8.tar.bz2
gentoo-2161ffcf29003bea270f6f077c6e4a7c14cc19b8.zip
app-shells/squirrelsh: EAPI 8
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/squirrelsh/squirrelsh-1.2.7-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-shells/squirrelsh/squirrelsh-1.2.7-r1.ebuild b/app-shells/squirrelsh/squirrelsh-1.2.7-r1.ebuild
index 1cde35292f6d..91c3a8e154d8 100644
--- a/app-shells/squirrelsh/squirrelsh-1.2.7-r1.ebuild
+++ b/app-shells/squirrelsh/squirrelsh-1.2.7-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit toolchain-funcs
+inherit edo toolchain-funcs
DESCRIPTION="Cross-platform object-oriented scripting shell using the squirrel language"
HOMEPAGE="http://squirrelsh.sourceforge.net/"
@@ -29,15 +29,15 @@ PATCHES=(
)
src_configure() {
- #This package uses a custom written configure script
- ./configure --prefix="${D}"/usr \
+ # This package uses a custom written configure script
+ edo ./configure --prefix="${D}"/usr \
--with-cc="$(tc-getCC)" \
--with-cpp="$(tc-getCXX)" \
--with-linker="$(tc-getCXX)" \
--libdir=/usr/"$(get_libdir)" \
--with-pcre="system" \
--with-squirrel="local" \
- --with-mime=no || die "configure failed"
+ --with-mime=no
}
src_install() {