summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2023-10-12 06:48:13 +0000
committerPatrick Lauer <patrick@gentoo.org>2023-10-12 06:50:25 +0000
commit216c8841d3dec99349669c12c03c373a3b447678 (patch)
treef7edfd98e9732ef83af6b355fedc2d93aaebc700
parentwww-client/chromium: drop 118.0.5993.54 (diff)
downloadgentoo-216c8841d3dec99349669c12c03c373a3b447678.tar.gz
gentoo-216c8841d3dec99349669c12c03c373a3b447678.tar.bz2
gentoo-216c8841d3dec99349669c12c03c373a3b447678.zip
sys-cluster/rdma-core: Fix lttng dep handling
CMakeList.txt has a small bug that accidentally breaks build. With default settings it would build as LTTNG is undefined, but since we set -DLTTNG=no explicitly it fails to build. Fix CMakeList.txt to restore sanity. Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--sys-cluster/rdma-core/rdma-core-48.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-48.0.ebuild b/sys-cluster/rdma-core/rdma-core-48.0.ebuild
index 19fe7450ce77..66f42a8b2e36 100644
--- a/sys-cluster/rdma-core/rdma-core-48.0.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-48.0.ebuild
@@ -67,6 +67,12 @@ PATCHES=(
"${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch
)
+src_prepare() {
+ # DEFINED is true even if the value is false, which makes lttng unconditional
+ sed -i -e 's/if (DEFINED ENABLE_LTTNG)/if (ENABLE_LTTNG)/' CMakeLists.txt || die
+ cmake_src_prepare
+}
+
src_configure() {
perl_set_version