summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-02-23 16:19:34 +0100
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-02-23 16:19:34 +0100
commit21779ce92c01f5c02bfd76cb30fd2eafe3dcb161 (patch)
treef0ee1da640bb2e01fc42731910ac503fad128862
parentdev-lang/spidermonkey: clean up old ebuilds (diff)
downloadgentoo-21779ce92c01f5c02bfd76cb30fd2eafe3dcb161.tar.gz
gentoo-21779ce92c01f5c02bfd76cb30fd2eafe3dcb161.tar.bz2
gentoo-21779ce92c01f5c02bfd76cb30fd2eafe3dcb161.zip
x11-drivers/xf86-video-amdgpu: Version bump.
Bug: https://bugs.gentoo.org/show_bug.cgi?id=568274 Package-Manager: portage-2.2.26
-rw-r--r--x11-drivers/xf86-video-amdgpu/Manifest1
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.0.1.ebuild28
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild5
3 files changed, 31 insertions, 3 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/Manifest b/x11-drivers/xf86-video-amdgpu/Manifest
index 0c8af44e7d9f..7eb3d5128485 100644
--- a/x11-drivers/xf86-video-amdgpu/Manifest
+++ b/x11-drivers/xf86-video-amdgpu/Manifest
@@ -1 +1,2 @@
DIST xf86-video-amdgpu-0.0.01_pre20150814.tar.xz 58024 SHA256 5654e22fcb051e04f5862576c84e8e7ab765f1097586874d3be75fefd49e159c SHA512 4885f92febd6ab1663c3b27b7db8af98eaa0d7f4c91c65e7ce8d9a8756ea0a051c65183d2d5fec3ed29b90d18de4bb81956bf585128f417a7e4471a12e2e9222 WHIRLPOOL 9b98505f0f9823661c084eaaad2e91bb2fb0956c07cf0cf22f6e4849ad9464134417f7caef9ab92c34e7881a24fabe8e6caa55300eebb3d887b04b150d42495d
+DIST xf86-video-amdgpu-1.0.1.tar.bz2 374443 SHA256 730fb959fc7a96643df10dc500bb645a94ac98fdfe021172a537a57c9cb3915e SHA512 ebc5822c615cb2ca9a058b222d3425a6d387b008ad9918454045a66b3985c596cba7df414972b99c1d30711b3c74739e6d74ab62ec25c469d880e0adcf833f80 WHIRLPOOL dc5a576bfea4a04152b7a745d913fdc317f0fd13df73a37a1909968eaea8edc0fff71cc71023e9fd74c60fed7976cfca58c221c55893026e858973970e9236a7
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.0.1.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.0.1.ebuild
new file mode 100644
index 000000000000..95627753c9c1
--- /dev/null
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_DRI="always"
+inherit xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ XORG_EAUTORECONF=yes
+ SRC_URI=""
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+
+IUSE="glamor"
+
+RDEPEND="x11-libs/libdrm[video_cards_amdgpu]
+ x11-base/xorg-server[glamor(-)?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS="$(use_enable glamor)"
+ xorg-2_src_configure
+}
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
index 7266714f6fe8..95627753c9c1 100644
--- a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
XORG_DRI="always"
-XORG_EAUTORECONF=yes
inherit xorg-2
if [[ ${PV} == 9999* ]]; then
+ XORG_EAUTORECONF=yes
SRC_URI=""
KEYWORDS=""
else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
fi