summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-10-05 07:44:01 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-05 07:44:01 -0400
commit217a3daeb7e95e0830b744228d4bd6910ead5ec1 (patch)
treea97138708432cae1f55b821607df6140dcf06cac
parentmedia-gfx/libimagequant: remove old (diff)
downloadgentoo-217a3daeb7e95e0830b744228d4bd6910ead5ec1.tar.gz
gentoo-217a3daeb7e95e0830b744228d4bd6910ead5ec1.tar.bz2
gentoo-217a3daeb7e95e0830b744228d4bd6910ead5ec1.zip
dev-python/django: remove old and vulnerable
Bug: https://bugs.gentoo.org/667456 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--dev-python/django/Manifest1
-rw-r--r--dev-python/django/django-2.1.1.ebuild87
2 files changed, 0 insertions, 88 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index e9b35c1ccfe6..066fbef99803 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -2,5 +2,4 @@ DIST Django-1.11.15.tar.gz 7843843 BLAKE2B b7713de8136302d8d95929ed449ab01173e28
DIST Django-1.11.16.tar.gz 7852514 BLAKE2B a881caa6c31c80d6b0146cb49a08ba63ebfba21637747328adb8ec3afada2182b72c46576a79cc9e163546e5b980a2be516d842492517319deb0a4f5512ad605 SHA512 bf1329ac364c9037fd6cecd0e8565c8bd8d830343671f9ce5415a10e70da37256667675b3f97e4d2508a8a912fa7a06ca7f585586ac18e6734c939bc41a8b455
DIST Django-2.0.8.tar.gz 7987343 BLAKE2B ab35f50ce1911cb9603c7ac85e7ab01e6019ce9a2dac4cd733b11f35722368946ff3a130c3c791da4d49cf609b5747b4c5de64e29e27a8e12abb7f9e29cd363b SHA512 ac3cc3f58cb977518c6f549834beb35677c2d5541cfb5723045b98165926e826178cb33737c52a0f999be24bc38b84dde489a5f91d1c8d51b8338aa611acb518
DIST Django-2.0.9.tar.gz 7992507 BLAKE2B c6f1d79401007d2c83553e885d5e32c7890b3f1ed53c948ea4c55cc2a0272c06d0b7fdafef7be5042ab26b3f8c3ffef64f6f01f49d6e615503f8bfad99b66c3a SHA512 7a766ce0240b19a18dc5a9a4682630c4ce90fa6ed0d02a97303088a990d09e097b609220f4e2806854585724f483cb2ae7e4f29bfd1898f3a0d6e758c2f4ea4a
-DIST Django-2.1.1.tar.gz 8595422 BLAKE2B b4d46162b8a48ada2e1321e6731afdfac8c6acbc394991178c33a374ea2d61d0b1f91ede6a56f9e88d20ba2ddbe6910fe452f79fc6cfb342fddc6222c454dad1 SHA512 e29180097cda0de35eb3dac77b7f7f3f31771257b9bfcd6d3fd37d421c572e1226bb1760635ccedee357cee7ca3dcb302de6126a771007a2cdef82970a596813
DIST Django-2.1.2.tar.gz 8611286 BLAKE2B 5107fd04ee11ae4ded3d8914d840e323e26617b526ab877654de08caa6ce1cb6f053d3afbdbdbda17ab26b1ed1bcb158ef092a63ef14393b87ed98e612cf43aa SHA512 3510f872762e75c7e66987857616d958d15bef91ce2d9e1656abcf4e0221b1c6ff72c59fd29643aa0b0288118db76d58023cffe48f401e7cdcd03d71822a282d
diff --git a/dev-python/django/django-2.1.1.ebuild b/dev-python/django/django-2.1.1.ebuild
deleted file mode 100644
index d2f6650c8d63..000000000000
--- a/dev-python/django/django-2.1.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{5,6,7} )
-PYTHON_REQ_USE='sqlite?,threads(+)'
-
-inherit bash-completion-r1 distutils-r1 eutils
-
-MY_PN="Django"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
-SRC_URI="https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-# admin fonts: Roboto (media-fonts/roboto)
-LICENSE+=" Apache-2.0"
-# admin icons, jquery, xregexp.js
-LICENSE+=" MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc sqlite test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
- test? (
- $(python_gen_impl_dep sqlite)
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.0.7-bashcomp.patch
-)
-
-python_prepare_all() {
- # Prevent d'loading in the doc build
- sed -e '/^ "sphinx.ext.intersphinx",/d' -i docs/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- PYTHONPATH=. "${PYTHON}" tests/runtests.py --settings=test_sqlite -v2 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- newbashcomp extras/django_bash_completion ${PN}-admin
- bashcomp_alias ${PN}-admin django-admin.py
-
- if use doc; then
- rm -fr docs/_build/html/_sources || die
- local HTML_DOCS=( docs/_build/html/. )
- fi
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "Additional Backend support can be enabled via"
- optfeature "MySQL backend support" dev-python/mysqlclient
- optfeature "PostgreSQL backend support" dev-python/psycopg:2
- echo ""
- elog "Other features can be enhanced by"
- optfeature "GEO Django" sci-libs/gdal[geos]
- optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
- optfeature "ImageField Support" dev-python/pillow
- optfeature "Password encryption" dev-python/bcrypt
- optfeature "High-level abstractions for Django forms" dev-python/django-formtools
-}