summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2021-07-10 16:23:22 -0500
committerJohn Helmert III <ajak@gentoo.org>2021-07-10 16:30:32 -0500
commit219086cb170df88a592359b93ca7e87cc8a26042 (patch)
tree12fd77bc6469476bcbb3066eb3a6466ce8ba3b38
parentdev-python/pytest-subtesthack: mark ALLARCHES (diff)
downloadgentoo-219086cb.tar.gz
gentoo-219086cb.tar.bz2
gentoo-219086cb.zip
dev-python/pytest-subtesthack: update EAPI 7 -> 8
Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..605571f39759
--- /dev/null
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
+HOMEPAGE="https://github.com/untitaker/pytest-subtesthack/"
+# pypi tarball misses tests
+SRC_URI="https://github.com/untitaker/pytest-subtesthack/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest