summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-02 22:08:43 -0500
committerMatt Turner <mattst88@gentoo.org>2024-03-02 23:24:12 -0500
commit21a439c83aebfba33a5c3e142e10498d28cfe7ce (patch)
treeea5181e82a7488dc921564bbd57533e5cd871b55
parentx11-libs/libXcursor: Version bump to 1.2.2 (diff)
downloadgentoo-21a439c83aebfba33a5c3e142e10498d28cfe7ce.tar.gz
gentoo-21a439c83aebfba33a5c3e142e10498d28cfe7ce.tar.bz2
gentoo-21a439c83aebfba33a5c3e142e10498d28cfe7ce.zip
x11-libs/libXaw3d: Version bump to 1.6.6
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libXaw3d/Manifest1
-rw-r--r--x11-libs/libXaw3d/libXaw3d-1.6.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/libXaw3d/Manifest b/x11-libs/libXaw3d/Manifest
index 0a51d6307d1d..31b47896cc15 100644
--- a/x11-libs/libXaw3d/Manifest
+++ b/x11-libs/libXaw3d/Manifest
@@ -1 +1,2 @@
DIST libXaw3d-1.6.5.tar.xz 483496 BLAKE2B 54dc1bb06b40685e3e2f00bc1aa8447a23ff61226c0b8d20cb0fe070bb7d914290cc4a5f2c70925da528bd9f02a283748178cb2b17111a56fbcc938a1eae25c9 SHA512 b2fbceffcbaff7c332f37769fd6b496ac820de8a80fbf9777416f1895b74a07e4efc3f2bd64db3f584983b24d2b10e9b60cf4aae3ec4a30c06510ae7c213a663
+DIST libXaw3d-1.6.6.tar.xz 482040 BLAKE2B d0c7be64283837a7b32f67a2671eebd6d608818819afc4055c360d46152a3348d895159e9a7b7321913b2fea5ec8c587043e921127043d4d37f929a4b71bd27d SHA512 f324ddb1117ae6f8d50137390b2e82b638b53a6b170cce8f7bd8108fd98ce956badc7dede6b49065419f1565f9f4304571880842e799f7f48fb36bebe3dc3603
diff --git a/x11-libs/libXaw3d/libXaw3d-1.6.6.ebuild b/x11-libs/libXaw3d/libXaw3d-1.6.6.ebuild
new file mode 100644
index 000000000000..898f3f1fbb68
--- /dev/null
+++ b/x11-libs/libXaw3d/libXaw3d-1.6.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw3d library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ xpm? ( x11-libs/libXpm )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --enable-internationalization
+ $(use_enable xpm multiplane-bitmaps)
+ --enable-gray-stipples
+ --enable-arrow-scrollbars
+ )
+ xorg-3_src_configure
+}