summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-03-24 22:04:27 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-03-24 22:04:27 +0900
commit21c59aa445e3f3053a39e89ec20421230afda7a7 (patch)
treef4007d010beec3fa0eb4b11fb2814f59849ae9a3
parentsys-apps/tcp-wrappers: Stabilize 7.6.31-r1 sparc, #927705 (diff)
downloadgentoo-21c59aa445e3f3053a39e89ec20421230afda7a7.tar.gz
gentoo-21c59aa445e3f3053a39e89ec20421230afda7a7.tar.bz2
gentoo-21c59aa445e3f3053a39e89ec20421230afda7a7.zip
app-shells/yash: new upstream release
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-shells/yash/Manifest1
-rw-r--r--app-shells/yash/yash-2.56.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index 0bc1764bbb3c..5c62226c23e8 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1 +1,2 @@
DIST yash-2.55.tar.xz 761184 BLAKE2B a6a73a4055766f310724bd78670870eb96be9c34f79c177a80d86876512adfdd9d67bb28fadd113cd230db5a7eaaa91a1926d1b942297ca735e7390460b7a8c0 SHA512 9e92fc86884b0b315a98fcb5da0f319f431515185a970762946b919ccccc72aa8756e337dfa7cec763a7d8496bf4838eb9ef88664b35512180f13cc4146e9816
+DIST yash-2.56.1.tar.xz 768752 BLAKE2B 8ee4c654e85b5895096870afcb3fc4e855274f3fd1956372753a46c522430a59c8ba96e64b0b13672e0289d2a9b6492a18a0f3d9e9e5500f53144ed1d56ca750 SHA512 28e8bde5fc12e5178136b82ecdc0c52c37c98301245089b0d55c43266880e299237a5522e572883e5c51b7d9a0e9bf94fe265a9ebdbf346c28ff837b0f60cc00
diff --git a/app-shells/yash/yash-2.56.1.ebuild b/app-shells/yash/yash-2.56.1.ebuild
new file mode 100644
index 000000000000..9084d796b0ba
--- /dev/null
+++ b/app-shells/yash/yash-2.56.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PLOCALES="en ja"
+
+inherit flag-o-matic plocale toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://magicant.github.io/yash/"
+SRC_URI="https://github.com/magicant/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC="$(tc-getCC)" \
+ LINGUAS="$(plocale_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}