summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-14 00:31:29 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-14 00:35:13 -0400
commit21d67dd1f21db33bb7d1611baa3727b378e47c96 (patch)
treedf5cf0bba011983144c8997791fcfaf275c12eb2
parentdev-python/urwid: Bump to 2.6.9 (diff)
downloadgentoo-21d67dd1f21db33bb7d1611baa3727b378e47c96.tar.gz
gentoo-21d67dd1f21db33bb7d1611baa3727b378e47c96.tar.bz2
gentoo-21d67dd1f21db33bb7d1611baa3727b378e47c96.zip
x11-terms/kitty: workaround simde issue with -mxop
Haven't actually tried bdver2 that bug #926959 used given hit illegal instructions mid-build, but should work in theory given it does with -mxop. Thankfully simde gives a lot of defines to control what it does, but ideally it should be looked at in simde itself upstream. Closes: https://bugs.gentoo.org/926959 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty/kitty-0.33.0.ebuild3
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild3
2 files changed, 6 insertions, 0 deletions
diff --git a/x11-terms/kitty/kitty-0.33.0.ebuild b/x11-terms/kitty/kitty-0.33.0.ebuild
index 72d581ffd389..cf3bee0036d7 100644
--- a/x11-terms/kitty/kitty-0.33.0.ebuild
+++ b/x11-terms/kitty/kitty-0.33.0.ebuild
@@ -145,6 +145,9 @@ src_compile() {
printf %s "${CFLAGS}"
)
+ # workaround simde bug with -mxop (bug #926959)
+ append-cppflags -DSIMDE_X86_XOP_NO_NATIVE=1
+
local conf=(
--disable-link-time-optimization
--ignore-compiler-warnings
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 72d581ffd389..cf3bee0036d7 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -145,6 +145,9 @@ src_compile() {
printf %s "${CFLAGS}"
)
+ # workaround simde bug with -mxop (bug #926959)
+ append-cppflags -DSIMDE_X86_XOP_NO_NATIVE=1
+
local conf=(
--disable-link-time-optimization
--ignore-compiler-warnings