summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-01-29 20:46:39 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-03 20:25:27 +0100
commit21fdd4546d25849fcf6494fe40826acc5ec49042 (patch)
treebd54bdbc87eb7662565a24df9b1a7836485a5537
parentnet-analyzer/authforce: take maintainership (diff)
downloadgentoo-21fdd454.tar.gz
gentoo-21fdd454.tar.bz2
gentoo-21fdd454.zip
net-analyzer/authforce: EAPI7, fix manpage installation
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-analyzer/authforce/authforce-0.9.9-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/authforce/authforce-0.9.9-r2.ebuild b/net-analyzer/authforce/authforce-0.9.9-r2.ebuild
new file mode 100644
index 000000000000..6bea4016bb12
--- /dev/null
+++ b/net-analyzer/authforce/authforce-0.9.9-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="An HTTP authentication brute forcer"
+HOMEPAGE="http://www.divineinvasion.net/authforce/"
+SRC_URI="http://www.divineinvasion.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="curl nls"
+
+RDEPEND="sys-libs/readline:0=
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-curl.patch
+ "${FILESDIR}"/${P}-locale.patch
+)
+
+src_prepare() {
+ default
+ gunzip doc/${PN}.1.gz
+ sed -i -e "s/${PN}.1.gz/${PN}.1/g" \
+ -e "s/\/mang/\/man1/g" doc/Makefile* || die
+}
+
+src_configure() {
+ econf \
+ $(use_with curl) \
+ $(use_enable nls) \
+ --with-path=/usr/share/${PN}/data:.
+}
+
+src_install() {
+ default
+ doman doc/${PN}.1
+}