summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-11-16 11:19:27 -0600
committerJohn Helmert III <ajak@gentoo.org>2022-11-16 11:23:23 -0600
commit220a34fb87577682cf03af955c65fc977a7d17db (patch)
treeb9ad71a7cbca99f0b71ff2c24abcb21f788940ea
parentdev-python/googleapis-common-protos: Bump to 1.57.0 (diff)
downloadgentoo-220a34fb.tar.gz
gentoo-220a34fb.tar.bz2
gentoo-220a34fb.zip
app-text/htmldoc: add 1.9.16
Bug: https://bugs.gentoo.org/780489 Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--app-text/htmldoc/Manifest1
-rw-r--r--app-text/htmldoc/htmldoc-1.9.16.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/htmldoc/Manifest b/app-text/htmldoc/Manifest
index ba674f8ca501..0b1b95718187 100644
--- a/app-text/htmldoc/Manifest
+++ b/app-text/htmldoc/Manifest
@@ -1 +1,2 @@
DIST htmldoc-1.9.11-source.tar.gz 4471815 BLAKE2B a76da0f5129d8d637c440ee1880bdc4c314db02294f8e7387abe28ab7f76a81b47c4670a27d34759f89b82e9b1d7c259d154fac7cb8c2b7caa6e1f99f3a35ebf SHA512 5ee6a61f129be9a7d26c554f1acb533f1edfbf34eefd8f4924e07bcead2680407c68b4e2c9840203d7bb07daf51ea18c422d7c04e33c4b346dd207531f330678
+DIST htmldoc-1.9.16-source.tar.gz 3389563 BLAKE2B 1c83e37313fb0a1196d4db3ddca47d4a418ab7aeb8f910c9a27178312a1b0239beddaf81f322b24dcf75dff7e838278fcfa0eed17b5aa493790de2393bcddebf SHA512 c901ed259ef8c0520ed03e314149e7a2fc3b5bffa9c8e9c6c3b023a8c9de1e37b7fa72d224fa7d072f3a5d4b379635d7cfaa016df672da296be8395b49fa935b
diff --git a/app-text/htmldoc/htmldoc-1.9.16.ebuild b/app-text/htmldoc/htmldoc-1.9.16.ebuild
new file mode 100644
index 000000000000..01ef5f97775f
--- /dev/null
+++ b/app-text/htmldoc/htmldoc-1.9.16.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs xdg
+
+DESCRIPTION="Convert HTML pages into a PDF document"
+HOMEPAGE="https://www.msweet.org/htmldoc/"
+SRC_URI="https://github.com/michaelrsweet/${PN}/releases/download/v${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="fltk ssl"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+ media-libs/libjpeg-turbo:=
+ >=media-libs/libpng-1.4:0=
+ sys-libs/zlib
+ ssl? ( net-libs/gnutls:= )
+ fltk? ( x11-libs/fltk:1 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # Fix the documentation path in a few places. Some Makefiles aren't
+ # autotoolized =(
+ for file in configure doc/Makefile doc/htmldoc.man; do
+ sed -i "${file}" \
+ -e "s:/doc/htmldoc:/doc/${PF}/html:g" \
+ || die "failed to fix documentation path in ${file}"
+ done
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with fltk gui)
+ $(use_enable ssl)
+ $(use_enable ssl gnutls)
+ )
+
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake STRIPPROG="true" DSTROOT="${ED}" install
+}