summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2023-04-16 11:08:31 -0700
committerJohn Helmert III <ajak@gentoo.org>2023-04-16 11:42:24 -0700
commit2218db506d4083a0a6a91f37ceab5057f4a93f4b (patch)
treeab889db83ccc055b65aa5602a8debb66dacda76a
parentdev-util/cutter: fix file collision with net-analyzer/cutter (diff)
downloadgentoo-2218db506d4083a0a6a91f37ceab5057f4a93f4b.tar.gz
gentoo-2218db506d4083a0a6a91f37ceab5057f4a93f4b.tar.bz2
gentoo-2218db506d4083a0a6a91f37ceab5057f4a93f4b.zip
dev-util/rizin: add 0.5.2 without broken tests
Bug: https://bugs.gentoo.org/904413 Signed-off-by: John Helmert III <ajak@gentoo.org>
-rw-r--r--dev-util/rizin/Manifest2
-rw-r--r--dev-util/rizin/rizin-0.5.2.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-util/rizin/Manifest b/dev-util/rizin/Manifest
index 518a6ae49d4c..08b725c3d8c3 100644
--- a/dev-util/rizin/Manifest
+++ b/dev-util/rizin/Manifest
@@ -1,4 +1,6 @@
DIST rizin-src-v0.4.1.tar.xz 11453808 BLAKE2B dcae21320e2533904d9a337d4fb9cc9a450439753106dc5c341e3ca7c788f0a44034340eb0dfe3fad4f1d8a7ebe873720d42d70ce343e8c7b953d4d148a38da2 SHA512 565358e11fd4db44ec7f8c25313a1cfc726c38a17afcb699c3fc2af520242fb343ea4a267f0a8e35bdc08e9a765a6a17ec7b8eaba9f9ad9ef5a7dcfe01c7354c
DIST rizin-src-v0.5.1.tar.xz 11770688 BLAKE2B 31369497d5aa425aa6030ce404baa5d4a10ef2453a93f9b2c9f7d47135b5ffbc61618ef7e743acef3939bca2838a94637b7a1794ff44998608aee3f988301483 SHA512 c856112651bec91bb6e9f5580f60e3168f02a9f194bf567186a66398c162f59953ca8c3bf43441315356ca6ef077b7c56e4150e2dd8a79d4d08c5f789c549596
+DIST rizin-src-v0.5.2.tar.xz 11779644 BLAKE2B d74c02c1f58d099a0047a7a528b7e182980901bc1bf2722aef259e03ddf9af908c3ebcde4f1268fcbd07125a21f064259601a54c6b8413e19f6b85c95113cf3d SHA512 2fbd3873c7725d4fa1dee53d685c4a5d372013f300cd19dd92752b82987f049a4eba77b4d4ae33b576678714752147355ac486951949a35275cc3fdc5447a351
DIST rizin-testbins-0264ae4ee5bd606ec6c6a539255eeb57ce2c82c2.tar.gz 179281553 BLAKE2B b86278589da2f8e5859b0f4b16e2667a6e7477c9a889158da5a2c1a1b6e29af4798d56a22dd4c3e23aec1908e7b444ca999502e73f8d8ccf4e0bf2a969380564 SHA512 ae11b6da5cb995f8f1cc996a7b772234b3e7e7c2b0695d0b223657ba839c82dbbcb390600aeb0d16c7c61a5037ba9d0739df79efd730c1b96392cfc1e6f6613d
DIST rizin-testbins-aef7f7b714a696f382f55b8cbbf94c5b69518de3.tar.gz 178497762 BLAKE2B 8c82a537a58e65d35bd8b309311c4377b5996ff4b650fc6cff4cf347e04fbe4b2ec0e88f03ff43572c8e99675186b05b393b7da070a60ab107c3cca829d2544b SHA512 2745b58646963c28a45b46e8e709845c355863e61cf796aeb3d2e617f1bf2f9916a4b106cd08f48b1ef6e36f7f38624b5977dcd62c921124b0a1122b7220baa8
+DIST rizin-testbins-d66f95359fe830514267f446975374752201c3f1.tar.gz 179428523 BLAKE2B 9d18c2f49460e26809bc526eab9d7bfed15d3fb3f94b22d327f9981547130f82107259f2942e098834cd8ad755e8eadb4b8459a10070105ec116b16fbac19fe3 SHA512 cdeefc6e4103e99c4581a45475c2326505f8003c80a158a78be32b27dfa65fe42a80bbf25ffc47c1f8abdd50faba0fb073a7236395ab67eafb0202695877c4ba
diff --git a/dev-util/rizin/rizin-0.5.2.ebuild b/dev-util/rizin/rizin-0.5.2.ebuild
new file mode 100644
index 000000000000..db47e015c5df
--- /dev/null
+++ b/dev-util/rizin/rizin-0.5.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+# This is the commit that the CI for the release commit used
+BINS_COMMIT="d66f95359fe830514267f446975374752201c3f1"
+
+inherit meson python-any-r1
+
+DESCRIPTION="reverse engineering framework for binary analysis"
+HOMEPAGE="https://rizin.re/"
+
+SRC_URI="mirror+https://github.com/rizinorg/rizin/releases/download/v${PV}/rizin-src-v${PV}.tar.xz
+ test? ( https://github.com/rizinorg/rizin-testbins/archive/${BINS_COMMIT}.tar.gz -> rizin-testbins-${BINS_COMMIT}.tar.gz )"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+LICENSE="Apache-2.0 BSD LGPL-3 MIT"
+SLOT="0/${PV}"
+IUSE="test"
+
+# Need to audit licenses of the binaries used for testing
+RESTRICT="test? ( fetch ) !test? ( test )"
+
+RDEPEND="
+ app-arch/lz4:0=
+ app-arch/xz-utils
+ dev-libs/capstone:0=
+ dev-libs/libmspack
+ dev-libs/libzip:0=
+ dev-libs/openssl:0=
+ >=dev-libs/tree-sitter-0.19.0
+ dev-libs/xxhash
+ sys-apps/file
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.4.0-never-rebuild-parser.patch"
+)
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_prepare() {
+ default
+
+ local py_to_mangle=(
+ librz/core/cmd_descs/cmd_descs_generate.py
+ sys/clang-format.py
+ test/fuzz/scripts/fuzz_rz_asm.py
+ test/scripts/gdbserver.py
+ )
+
+ python_fix_shebang "${py_to_mangle[@]}"
+
+ # https://github.com/rizinorg/rizin/issues/3459
+ sed -ie '/dyld_chained_ptr_arm64e_auth/d' test/unit/test_bin_mach0.c || die
+
+ if use test; then
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}/test/bins" || die
+ cp -r "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}" || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcli=enabled
+ -Duse_sys_capstone=enabled
+ -Duse_sys_libmspack=enabled
+ -Duse_sys_libzip=enabled
+ -Duse_sys_lz4=enabled
+ -Duse_sys_lzma=enabled
+ -Duse_sys_magic=enabled
+ -Duse_sys_openssl=enabled
+ -Duse_sys_tree_sitter=enabled
+ -Duse_sys_xxhash=enabled
+ -Duse_sys_zlib=enabled
+
+ $(meson_use test enable_tests)
+ $(meson_use test enable_rz_test)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # We can select running either unit or integration tests, or all of
+ # them by not passing --suite. According to upstream, integration
+ # tests are more fragile and unit tests are sufficient for testing
+ # packaging, so only run those.
+ meson_src_test --suite unit
+}