summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-20 08:28:28 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-20 13:09:48 +0200
commit222747f9e63ab80447fb6ef0b67f53070f805f64 (patch)
treef83a7621deebaef54a11adab894a3d1ec4fd6a41
parentdev-python/tifffile: Bump to 2023.7.18 (diff)
downloadgentoo-222747f9e63ab80447fb6ef0b67f53070f805f64.tar.gz
gentoo-222747f9e63ab80447fb6ef0b67f53070f805f64.tar.bz2
gentoo-222747f9e63ab80447fb6ef0b67f53070f805f64.zip
dev-python/caldav: Bump to 1.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/caldav/Manifest1
-rw-r--r--dev-python/caldav/caldav-1.3.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index fd9141110a0e..bfc982d8ebfa 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1 +1,2 @@
DIST caldav-1.2.1.gh.tar.gz 122700 BLAKE2B 21b8ddf512371d192aa2360a0f7bba4b7377defb1cdd830a4c78be86bf3a44689733cd742337a60894b99d0e80615b4005b620a7e8159d7ca708eb9fe1401402 SHA512 788b92a92f4d986b37fa8e237a5cbb3e18a7f596f7799362cf999b7b4981572de7982b352ffd835a51a583bc61eaf8d62fb5bdd31d07377197db887c54ce65bd
+DIST caldav-1.3.5.gh.tar.gz 122421 BLAKE2B 049ca9bfa2aee3475a15b388c7ba07f0bdf4c51893fb4cb16ce3d56df269e4514727b28540c2e84176242f8ad5216635885fda5d9ee3789235093136f9a6e586 SHA512 d249548542f70fd15b08275cf9fc086843263d4b54b45816542a01cfeba78cc869623cc8fe010acc31faaa301b7b163e85ff4899e4be1282bd3869cb2c2c2b8e
diff --git a/dev-python/caldav/caldav-1.3.5.ebuild b/dev-python/caldav/caldav-1.3.5.ebuild
new file mode 100644
index 000000000000..15e769c20e0b
--- /dev/null
+++ b/dev-python/caldav/caldav-1.3.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav/
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/recurring-ical-events-2.0.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest