summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-08 08:06:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-08 08:21:16 +0200
commit22485b3417da2146e6280ef7bbd9065aebaadb4b (patch)
treebe81ed7fccb7cc53b0079a3dd742a80d2701df51
parentdev-ruby/slim: fix tests (diff)
downloadgentoo-22485b34.tar.gz
gentoo-22485b34.tar.bz2
gentoo-22485b34.zip
dev-python/portend: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/portend/Manifest1
-rw-r--r--dev-python/portend/portend-3.0.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/portend/Manifest b/dev-python/portend/Manifest
index 973499df5247..2de0a1b69d9e 100644
--- a/dev-python/portend/Manifest
+++ b/dev-python/portend/Manifest
@@ -1 +1,2 @@
DIST portend-2.7.1.tar.gz 13538 BLAKE2B 56e9b7ae4fb9371322cbecf12d9367fc48f0138cf9fa8cb25cf7f0b7977d83852f328d89e93ee2e266e77b393bbabe75d091ce85f688e1ee146edf64e470aa60 SHA512 079bfc286491753e980b5000ee716031225439523a8d9a79c2571359adee74ee024dd680c41adb966487dc39eea3d0dbeb928c5c72fa21ab897283310ef21906
+DIST portend-3.0.0.tar.gz 9439 BLAKE2B 50c6455c8d5ad51e1b523d4aa150ffc5a607a35d3c6fed4d2f686f2fa7fd7eefbe00bf0a033b9178b205e5bba5650e3de484c66d824f41b259ea031b985d2ccd SHA512 7228d454e7d22317de3462edb1e2f1b7fcf29e4601c9373709d80260ea5964c0dd4fbc39543e27a7f375b478ca119b285e47fac6ffda41401399cbe7bf485c8c
diff --git a/dev-python/portend/portend-3.0.0.ebuild b/dev-python/portend/portend-3.0.0.ebuild
new file mode 100644
index 000000000000..9fab7d4fe38b
--- /dev/null
+++ b/dev-python/portend/portend-3.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="TCP port monitoring utilities"
+HOMEPAGE="https://pypi.org/project/portend/ https://github.com/jaraco/portend"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/tempora-1.8[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest