summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-16 17:45:19 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-16 20:24:18 +0200
commit2250f3a16a7a19a627c05851f64768d1ad7317a0 (patch)
tree8643f8d17f70bd03918d98b073180cef8d92ca41
parentdev-util/bazel: Bump to version 3.7.2 (diff)
downloadgentoo-2250f3a1.tar.gz
gentoo-2250f3a1.tar.bz2
gentoo-2250f3a1.zip
dev-python/pytest-env: new package
Test dependency of dev-vcs/pre-commit. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/pytest-env/Manifest1
-rw-r--r--dev-python/pytest-env/metadata.xml12
-rw-r--r--dev-python/pytest-env/pytest-env-0.6.2.ebuild17
3 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-env/Manifest b/dev-python/pytest-env/Manifest
new file mode 100644
index 000000000000..217812163a3a
--- /dev/null
+++ b/dev-python/pytest-env/Manifest
@@ -0,0 +1 @@
+DIST pytest-env-0.6.2.tar.gz 1693 BLAKE2B b303b8b2b486cd5f6c6273fefe709e3986183a56b6758b05f8bde973c561ebba9646538d38783749305740d8bd637966966a109fcd600cd6f6ee059449ffb328 SHA512 0b3bb21fc881023c102b584593c6e28840400ce8190810f33f9a421df4141e17dcfad2943c4159aaab82376b7b47b07b45f97c9cb232a7d17c4d35b55966596d
diff --git a/dev-python/pytest-env/metadata.xml b/dev-python/pytest-env/metadata.xml
new file mode 100644
index 000000000000..fbf280e55267
--- /dev/null
+++ b/dev-python/pytest-env/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">MobileDynasty/pytest-env</remote-id>
+ <remote-id type="pypi">pytest-env</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-env/pytest-env-0.6.2.ebuild b/dev-python/pytest-env/pytest-env-0.6.2.ebuild
new file mode 100644
index 000000000000..ae67df12a297
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-0.6.2.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that allows you to add environment variables"
+HOMEPAGE="https://github.com/MobileDynasty/pytest-env"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"