summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-01 06:05:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-01 06:31:01 +0200
commit226fbc49f94a0b5866f35a3b7c4e06324b4117c4 (patch)
treed1878c222696c7ab533ea6792fd7c702aa4625ec
parentdev-python/hypothesis: Bump to 6.75.1 (diff)
downloadgentoo-226fbc49f94a0b5866f35a3b7c4e06324b4117c4.tar.gz
gentoo-226fbc49f94a0b5866f35a3b7c4e06324b4117c4.tar.bz2
gentoo-226fbc49f94a0b5866f35a3b7c4e06324b4117c4.zip
dev-python/jc: Bump to 1.23.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jc/Manifest1
-rw-r--r--dev-python/jc/jc-1.23.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jc/Manifest b/dev-python/jc/Manifest
index def66d6b542d..0073046d8337 100644
--- a/dev-python/jc/Manifest
+++ b/dev-python/jc/Manifest
@@ -1 +1,2 @@
DIST jc-1.23.1.gh.tar.gz 12853550 BLAKE2B b10c3688025c35b4f71345756b6efd93af1e8abe2a343ca66e9f658d986f7ce60c04526d65a27286425f1f24c188de3e2ba923e4304a8e669139006db1d53766 SHA512 6f2936b6c42136909ff04233cbabbf0a5827552d83f29131c42cbc4de20a3b7fee2263a5cdec9c596d39fb3edc26dbc56863631e992d124c038c53490ba37ebf
+DIST jc-1.23.2.gh.tar.gz 12866729 BLAKE2B 8c37611e75952533fbbb1ac2a4dbf9fc95d6764452bc619da2fb4a0e5b870f3314061276eb5ce0f98f69fd26ae5b0f083443c7840a1254f5934d9b210d7fe4a2 SHA512 bf3b846e359fdece1445d9ca70e7752db05894f97d4c1ca162ef397ffea9e3e719dbb71d496cd0565649ebe47f977d7ef7689e360470b29639523f24b45fcdec
diff --git a/dev-python/jc/jc-1.23.2.ebuild b/dev-python/jc/jc-1.23.2.ebuild
new file mode 100644
index 000000000000..1a55e5e1e8dd
--- /dev/null
+++ b/dev-python/jc/jc-1.23.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+# no tests in sdist, as of 1.23.2
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest