summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-20 10:00:04 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-20 10:01:34 +0200
commit22795f7a23c79d79f08445d39291991391065e49 (patch)
treed6ee4e4c7db0ce0564c27c20ce7f109defa0a488
parentdev-util/debugedit: Drop old (diff)
downloadgentoo-22795f7a23c79d79f08445d39291991391065e49.tar.gz
gentoo-22795f7a23c79d79f08445d39291991391065e49.tar.bz2
gentoo-22795f7a23c79d79f08445d39291991391065e49.zip
dev-libs/beecrypt: Remove last-rited pkg
Closes: https://bugs.gentoo.org/680322 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/beecrypt/Manifest1
-rw-r--r--dev-libs/beecrypt/beecrypt-4.2.1-r6.ebuild104
-rw-r--r--dev-libs/beecrypt/files/beecrypt-4.2.1-build-system.patch160
-rw-r--r--dev-libs/beecrypt/files/beecrypt-4.2.1-c++11-allow-throw-in-destructors.patch26
-rw-r--r--dev-libs/beecrypt/files/beecrypt-4.2.1-cast-uchar.patch214
-rw-r--r--dev-libs/beecrypt/files/beecrypt-4.2.1-gcc-4.7.patch11
-rw-r--r--dev-libs/beecrypt/files/beecrypt-4.2.1-icu-61.patch51
-rw-r--r--dev-libs/beecrypt/metadata.xml8
-rw-r--r--profiles/arch/arm/package.use.mask1
-rw-r--r--profiles/package.mask9
10 files changed, 0 insertions, 585 deletions
diff --git a/dev-libs/beecrypt/Manifest b/dev-libs/beecrypt/Manifest
deleted file mode 100644
index 0fc625fdb93f..000000000000
--- a/dev-libs/beecrypt/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST beecrypt-4.2.1.tar.gz 882758 BLAKE2B 7ca25613cf95df8657c762d932618979783ea2ddfbaecdf066701d61a5f9ac76bd474a51eb65e140c83ef01880477cb7104e3d67c2fc078ae7b710637d18bb53 SHA512 59995d53c024efe6344a21ac0d6d55fbe652488a4a22cc6719f9fc3851d56697fa8738937d48aa1e6f9ebe749de61ac3c79a5f0cea793872213c3bdf922e71bc
diff --git a/dev-libs/beecrypt/beecrypt-4.2.1-r6.ebuild b/dev-libs/beecrypt/beecrypt-4.2.1-r6.ebuild
deleted file mode 100644
index 6d5604389d3e..000000000000
--- a/dev-libs/beecrypt/beecrypt-4.2.1-r6.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit autotools flag-o-matic java-pkg-opt-2 python-single-r1
-
-DESCRIPTION="General-purpose cryptography library"
-HOMEPAGE="https://sourceforge.net/projects/beecrypt/"
-SRC_URI="mirror://sourceforge/beecrypt/${P}.tar.gz"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="+threads java cxx python static-libs doc"
-REQUIRED_USE="cxx? ( threads )
- python? ( ${PYTHON_REQUIRED_USE} )"
-
-COMMON_DEPEND="!<app-arch/rpm-4.2.1
- cxx? ( >=dev-libs/icu-6.1:= )
- python? ( ${PYTHON_DEPS} )"
-
-DEPEND="${COMMON_DEPEND}
- java? ( >=virtual/jdk-1.4 )
- doc? ( app-doc/doxygen
- virtual/latex-base
- dev-texlive/texlive-fontsextra
- )"
-RDEPEND="${COMMON_DEPEND}
- java? ( >=virtual/jre-1.4 )"
-
-DOCS=( BUGS README BENCHMARKS NEWS )
-PATCHES=(
- "${FILESDIR}"/${P}-build-system.patch
- "${FILESDIR}"/${P}-gcc-4.7.patch
-
- # Fixes bug 596904
- "${FILESDIR}"/${P}-c++11-allow-throw-in-destructors.patch
- "${FILESDIR}"/${P}-cast-uchar.patch #618676
-
- "${FILESDIR}"/${P}-icu-61.patch
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- java-pkg-opt-2_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # ICU needs char16_t support now
- # bug 649548
- append-cxxflags -std=c++14
-
- # Crudely disable amd64 assembly code
- # as it assumes 64-bit 'unsinged long' size. bug #461960
- local x32_hack=()
- use amd64 && [[ ${ABI} == "x32" ]] && x32_hack=(--enable-debug)
-
- # cplusplus needs threads support
- ac_cv_java_include=$(use java && java-pkg_get-jni-cflags) \
- econf \
- --disable-expert-mode \
- $(use_enable static-libs static) \
- $(use_enable threads) \
- $(use_with python python "${PYTHON}") \
- $(use_with cxx cplusplus) \
- $(use_with java) \
- "${x32_hack[@]}"
-}
-
-src_compile() {
- default
-
- if use doc; then
- pushd include/beecrypt >/dev/null || die
- doxygen || die "doxygen failed"
- popd >/dev/null || die
- HTML_DOCS=( docs/html/*.{css,html,js,png} )
- fi
-}
-
-src_test() {
- export BEECRYPT_CONF_FILE="${T}/beecrypt-test.conf"
- echo "provider.1=${S}/c++/provider/.libs/base.so" > "${BEECRYPT_CONF_FILE}" || die
- emake check bench
-}
-
-src_install() {
- default
-
- if use python; then
- rm -f "${D%/}$(python_get_sitedir)"/_bc.*a || die
- fi
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
-}
diff --git a/dev-libs/beecrypt/files/beecrypt-4.2.1-build-system.patch b/dev-libs/beecrypt/files/beecrypt-4.2.1-build-system.patch
deleted file mode 100644
index e35095f53b6e..000000000000
--- a/dev-libs/beecrypt/files/beecrypt-4.2.1-build-system.patch
+++ /dev/null
@@ -1,160 +0,0 @@
---- beecrypt-4.2.1/configure.ac
-+++ beecrypt-4.2.1/configure.ac
-@@ -11,7 +11,7 @@
-
- # Checks for package options
- AC_ARG_ENABLE(expert-mode, [ --enable-expert-mode follow user-defined CFLAGS settings [[default=no]]],[
-- ac_enable_expert_mode=yes
-+ ac_enable_expert_mode=$enableval
- ],[
- if test "X$CFLAGS" != "X"; then
- echo "enabling expert mode"
-@@ -25,7 +25,7 @@
- if test "$ac_enable_expert_mode" = yes; then
- AC_MSG_ERROR([--enable-debug cannot be used in conjunction with --enable-expert-mode])
- fi
-- ac_enable_debug=yes
-+ ac_enable_debug=$enableval
- ],[
- ac_enable_debug=no
- ])
-@@ -456,7 +456,7 @@
- ac_cv_python_include="-I`$PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_inc()'`"
- ])
- AC_CACHE_CHECK([where to install python libraries], ac_cv_python_libdir, [
-- ac_cv_python_libdir=`$PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib()'`
-+ ac_cv_python_libdir=`$PYTHON -c 'import distutils.sysconfig; print distutils.sysconfig.get_python_lib(1, 0)'`
- ])
- fi
- fi
---- beecrypt-4.2.1/acinclude.m4
-+++ beecrypt-4.2.1/acinclude.m4
-@@ -498,15 +498,6 @@ AC_DEFUN([BEE_GNU_CC],[
- AC_SUBST(OPENMP_LIBS,"-lgomp")
- fi
- case $bc_target_arch in
-- x86_64 | athlon64 | athlon-fx | k8 | opteron | em64t | nocona)
-- CC="$CC -m64"
-- ;;
-- i[[3456]]86 | \
-- pentium* | \
-- athlon*)
-- CC="$CC -m32"
-- CCAS="$CCAS -m32"
-- ;;
- ia64)
- case $target_os in
- # HP/UX on Itanium needs to be told that a long is 64-bit!
-@@ -525,17 +516,8 @@ AC_DEFUN([BEE_GNU_CC],[
- aix*)
- CC="$CC -maix64"
- ;;
-- linux*)
-- CC="$CC -m64"
-- ;;
- esac
- ;;
-- sparc | sparcv8*)
-- CC="$CC -m32"
-- ;;
-- sparc64 | sparcv9*)
-- CC="$CC -m64"
-- ;;
- esac
- # Certain platforms needs special flags for multi-threaded code
- if test "$ac_enable_threads" = yes; then
-@@ -646,14 +646,6 @@ dnl BEE_GNU_CXX
- AC_DEFUN([BEE_GNU_CXX],[
- AC_REQUIRE([AC_PROG_CXX])
- case $bc_target_arch in
-- x86_64 | athlon64 | athlon-fx | k8 | opteron | em64t | nocona | core2)
-- CXX="$CXX -m64"
-- ;;
-- i[[3456]]86 | \
-- pentium* | \
-- athlon*)
-- CXX="$CXX -m32"
-- ;;
- ia64)
- case $target_os in
- # HP/UX on Itanium needs to be told that a long is 64-bit!
-@@ -672,17 +664,8 @@ AC_DEFUN([BEE_GNU_CXX],[
- aix*)
- CXX="$CXX -maix64"
- ;;
-- linux*)
-- CXX="$CXX -m64"
-- ;;
- esac
- ;;
-- sparc | sparcv8*)
-- CXX="$CXX -m32"
-- ;;
-- sparc64 | sparcv9*)
-- CXX="$CXX -m64"
-- ;;
- esac
- # Certain platforms needs special flags for multi-threaded code
- if test "$ac_enable_threads" = yes; then
---- beecrypt-4.2.1/java/Makefile.am
-+++ beecrypt-4.2.1/java/Makefile.am
-@@ -26,7 +26,7 @@
-
- INCLUDES = -I$(top_srcdir)/include
-
--libaltdir=$(prefix)/lib@LIBALT@
-+libaltdir=$(libdir)
-
- libalt_LTLIBRARIES = libbeecrypt_java.la
-
---- beecrypt-4.2.1/acinclude.m4
-+++ beecrypt-4.2.1/acinclude.m4
-@@ -1589,20 +1589,5 @@
- AC_SUBST(TYPEDEF_BC_THREADID_T,$bc_typedef_bc_threadid_t)
- ])
--
--AH_BOTTOM([
--#if ENABLE_THREADS
--# ifndef _REENTRANT
--# define _REENTRANT
--# endif
--# if LINUX
--# define _LIBC_REENTRANT
--# endif
--#else
--# ifdef _REENTRANT
--# undef _REENTRANT
--# endif
--#endif
--])
-
-
- dnl BEE_THREAD_LOCAL_STORAGE
-@@ -1623,7 +1609,5 @@
- ])
-
- AH_BOTTOM([
--#if !ENABLE_THREAD_LOCAL_STORAGE
--# define __thread
--#endif
-+#include "config.threads.h"
- ])
---- beecrypt-4.2.1/config.threads.h
-+++ beecrypt-4.2.1/config.threads.h
-@@ -0,0 +1,16 @@
-+#if ENABLE_THREADS
-+# ifndef _REENTRANT
-+# define _REENTRANT
-+# endif
-+# if LINUX
-+# define _LIBC_REENTRANT
-+# endif
-+#else
-+# ifdef _REENTRANT
-+# undef _REENTRANT
-+# endif
-+#endif
-+
-+#if !ENABLE_THREAD_LOCAL_STORAGE
-+# define __thread
-+#endif
diff --git a/dev-libs/beecrypt/files/beecrypt-4.2.1-c++11-allow-throw-in-destructors.patch b/dev-libs/beecrypt/files/beecrypt-4.2.1-c++11-allow-throw-in-destructors.patch
deleted file mode 100644
index 0cb291d8ff15..000000000000
--- a/dev-libs/beecrypt/files/beecrypt-4.2.1-c++11-allow-throw-in-destructors.patch
+++ /dev/null
@@ -1,26 +0,0 @@
---- beecrypt-4.2.1/include/beecrypt/c++/lang/Object.h.old 2016-10-12 18:40:10.878868563 -0400
-+++ beecrypt-4.2.1/include/beecrypt/c++/lang/Object.h 2016-10-12 19:17:22.508857979 -0400
-@@ -145,7 +145,11 @@
- waiter* prev;
-
- waiter(bc_threadid_t owner, unsigned int lock_count);
-+#if __cplusplus < 201103L
- ~waiter();
-+#else
-+ ~waiter() noexcept(false);
-+#endif
- };
-
- waiter* _lock_head;
---- beecrypt-4.2.1/c++/lang/Object.cxx.old 2016-10-12 18:40:39.024665316 -0400
-+++ beecrypt-4.2.1/c++/lang/Object.cxx 2016-10-12 19:14:41.630529720 -0400
-@@ -767,6 +767,9 @@
- }
-
- Object::FairMonitor::waiter::~waiter()
-+#if __cplusplus >= 201103L
-+noexcept(false)
-+#endif
- {
- #if WIN32
- if (!CloseHandle(event))
diff --git a/dev-libs/beecrypt/files/beecrypt-4.2.1-cast-uchar.patch b/dev-libs/beecrypt/files/beecrypt-4.2.1-cast-uchar.patch
deleted file mode 100644
index 8efedc01e4aa..000000000000
--- a/dev-libs/beecrypt/files/beecrypt-4.2.1-cast-uchar.patch
+++ /dev/null
@@ -1,214 +0,0 @@
-beecrypt's c++ api uses jchar arrays for strings, while ICU 59 expects
-char16_t type
-
-In practice these both seem to be defined as short int on amd64 so it
-might be okay to just reinterpret_cast them? There's probably no easy
-way out on a platform where char16_t won't match jchar
-
-Patch by Valeriy Malov <jazzvoid@gmail.com>
-https://bugs.gentoo.org/618676
-
---- a/c++/io/DataInputStream.cxx
-+++ b/c++/io/DataInputStream.cxx
-@@ -201,7 +201,7 @@ String DataInputStream::readUTF() throw (IOException)
- jchar* buffer = new jchar[ulen+1];
-
- status = U_ZERO_ERROR;
-- ucnv_toUChars(_utf, buffer, ulen+1, (const char*) data, (jint) utflen, &status);
-+ ucnv_toUChars(_utf, reinterpret_cast<UChar*>(buffer), ulen+1, (const char*) data, (jint) utflen, &status);
-
- delete[] data;
-
-@@ -232,7 +232,7 @@ String DataInputStream::readLine() throw (IOException)
-
- array<jchar> target_buffer(80);
- jint target_offset = 0;
-- UChar* target = target_buffer.data();
-+ UChar* target = reinterpret_cast<UChar*>(target_buffer.data());
- const UChar* target_limit = target+1;
- char source_buffer[MAX_BYTES_PER_CHARACTER];
- const char* source = source_buffer;
---- a/c++/io/DataOutputStream.cxx
-+++ b/c++/io/DataOutputStream.cxx
-@@ -187,7 +187,7 @@ void DataOutputStream::writeUTF(const String& str) throw (IOException)
- const array<jchar>& src = str.toCharArray();
-
- // the expected status code here is U_BUFFER_OVERFLOW_ERROR
-- jint need = ucnv_fromUChars(_utf, 0, 0, src.data(), src.size(), &status);
-+ jint need = ucnv_fromUChars(_utf, 0, 0, reinterpret_cast<const UChar*>(src.data()), src.size(), &status);
- if (U_FAILURE(status))
- if (status != U_BUFFER_OVERFLOW_ERROR)
- throw IOException("ucnv_fromUChars failed");
-@@ -200,7 +200,7 @@ void DataOutputStream::writeUTF(const String& str) throw (IOException)
- status = U_ZERO_ERROR;
-
- // the expected status code here is U_STRING_NOT_TERMINATED_WARNING
-- ucnv_fromUChars(_utf, (char*) buffer, need, src.data(), src.size(), &status);
-+ ucnv_fromUChars(_utf, (char*) buffer, need, reinterpret_cast<const UChar*>(src.data()), src.size(), &status);
- if (status != U_STRING_NOT_TERMINATED_WARNING)
- {
- delete[] buffer;
---- a/c++/io/PrintStream.cxx
-+++ b/c++/io/PrintStream.cxx
-@@ -191,7 +191,7 @@ void PrintStream::print(jchar ch) throw ()
- UErrorCode status = U_ZERO_ERROR;
-
- // do conversion of one character
-- size_t used = ucnv_fromUChars(_loc, buffer, 8, &ch, 1, &status);
-+ size_t used = ucnv_fromUChars(_loc, buffer, 8, reinterpret_cast<UChar*>(&ch), 1, &status);
- if (U_FAILURE(status))
- throw IOException("failure in ucnv_fromUChars");
-
-@@ -268,14 +268,14 @@ void PrintStream::print(jlong x) throw ()
-
- void PrintStream::print(const array<jchar>& chars) throw ()
- {
-- print(chars.data(), chars.size());
-+ print(reinterpret_cast<const UChar*>(chars.data()), chars.size());
- }
-
- void PrintStream::print(const String& str) throw ()
- {
- const array<jchar>& tmp = str.toCharArray();
-
-- print(tmp.data(), tmp.size());
-+ print(reinterpret_cast<const UChar*>(tmp.data()), tmp.size());
- }
-
- void PrintStream::println() throw ()
---- a/c++/lang/String.cxx
-+++ b/c++/lang/String.cxx
-@@ -33,6 +33,8 @@ using namespace beecrypt::lang;
- #include <unicode/ustdio.h>
- #include <unicode/ustring.h>
-
-+static_assert(sizeof(jchar) == sizeof(UChar), "jchar and UChar sizes mismatch");
-+
- String::String(array<jchar>& swapWith)
- {
- assert(swapWith.size() <= Integer::MAX_VALUE);
-@@ -56,7 +58,7 @@ String::String()
-
- String::String(char c) : _value(1)
- {
-- u_charsToUChars(&c, _value.data(), 1);
-+ u_charsToUChars(&c, reinterpret_cast<UChar*>(_value.data()), 1);
- }
-
- String::String(jchar c) : _value(&c, 1)
-@@ -67,7 +69,7 @@ String::String(const char* value) : _value(::strlen(value))
- {
- assert(_value.size() <= Integer::MAX_VALUE);
-
-- u_charsToUChars(value, _value.data(), _value.size());
-+ u_charsToUChars(value, reinterpret_cast<UChar*>(_value.data()), _value.size());
- }
-
- String::String(const jchar* value, int offset, int length) : _value(value+offset, length)
-@@ -449,7 +451,7 @@ std::ostream& beecrypt::lang::operator<<(std::ostream& stream, const String& str
- if (U_FAILURE(status))
- throw RuntimeException("ucnv_open failed");
-
-- int need = ucnv_fromUChars(loc, 0, 0, src.data(), src.size(), &status);
-+ int need = ucnv_fromUChars(loc, 0, 0, reinterpret_cast<const UChar*>(src.data()), src.size(), &status);
- if (U_FAILURE(status))
- if (status != U_BUFFER_OVERFLOW_ERROR)
- throw RuntimeException("ucnv_fromUChars failed");
-@@ -458,7 +460,7 @@ std::ostream& beecrypt::lang::operator<<(std::ostream& stream, const String& str
-
- status = U_ZERO_ERROR;
-
-- ucnv_fromUChars(loc, out, need+1, src.data(), src.size(), &status);
-+ ucnv_fromUChars(loc, out, need+1, reinterpret_cast<const UChar*>(src.data()), src.size(), &status);
- if (U_FAILURE(status))
- throw RuntimeException("ucnv_fromUChars failed");
-
---- a/c++/lang/StringBuffer.cxx
-+++ b/c++/lang/StringBuffer.cxx
-@@ -35,7 +35,7 @@ StringBuffer::StringBuffer() : _buffer(16)
-
- StringBuffer::StringBuffer(const char* s) : _buffer(16 + strlen(s))
- {
-- u_charsToUChars(s, _buffer.data(), _used = strlen(s));
-+ u_charsToUChars(s, reinterpret_cast<UChar*>(_buffer.data()), _used = strlen(s));
- }
-
- StringBuffer::StringBuffer(const String& s) : _buffer(16 + s._value.size())
-@@ -53,7 +53,7 @@ StringBuffer& StringBuffer::append(char c)
- synchronized (this)
- {
- core_ensureCapacity(_used+1);
-- u_charsToUChars(&c, _buffer.data() + _used++, 1);
-+ u_charsToUChars(&c, reinterpret_cast<UChar*>(_buffer.data() + _used++), 1);
- }
- return *this;
- }
-@@ -88,7 +88,7 @@ StringBuffer& StringBuffer::append(const char* s)
- jint need = strlen(s);
-
- core_ensureCapacity(_used + need);
-- u_charsToUChars(s, _buffer.data() + _used, need);
-+ u_charsToUChars(s, reinterpret_cast<UChar*>(_buffer.data() + _used), need);
-
- _used += need;
- }
---- a/c++/lang/StringBuilder.cxx
-+++ b/c++/lang/StringBuilder.cxx
-@@ -38,7 +38,7 @@ StringBuilder::StringBuilder() : _buffer(16)
-
- StringBuilder::StringBuilder(const char* s) : _buffer(16 + strlen(s))
- {
-- u_charsToUChars(s, _buffer.data(), _used = strlen(s));
-+ u_charsToUChars(s, reinterpret_cast<UChar*>(_buffer.data()), _used = strlen(s));
- }
-
- StringBuilder::StringBuilder(const String& s) : _buffer(16 + s._value.size())
-@@ -55,7 +55,7 @@ StringBuilder& StringBuilder::append(char c)
- {
- ensureCapacity(_used+1);
-
-- u_charsToUChars(&c, _buffer.data() + _used++, 1);
-+ u_charsToUChars(&c, reinterpret_cast<UChar*>(_buffer.data() + _used++), 1);
-
- return *this;
- }
-@@ -97,7 +97,7 @@ StringBuilder& StringBuilder::append(const char* s)
-
- ensureCapacity(_used + need);
-
-- u_charsToUChars(s, _buffer.data() + _used, need);
-+ u_charsToUChars(s, reinterpret_cast<UChar*>(_buffer.data() + _used), need);
-
- _used += need;
-
---- a/c++/security/Provider.cxx
-+++ b/c++/security/Provider.cxx
-@@ -90,7 +90,7 @@ Object* Provider::setProperty(const String& key, const String& value)
-
- UErrorCode status = U_ZERO_ERROR;
-
-- ucnv_fromUChars(_conv, symname, 1024, src.data(), src.size(), &status);
-+ ucnv_fromUChars(_conv, symname, 1024, reinterpret_cast<const UChar*>(src.data()), src.size(), &status);
-
- if (status != U_ZERO_ERROR)
- throw RuntimeException("error in ucnv_fromUChars");
---- a/c++/security/Security.cxx
-+++ b/c++/security/Security.cxx
-@@ -104,7 +104,7 @@ void Security::initialize()
-
- const array<jchar>& src = value->toCharArray();
-
-- int need = ucnv_fromUChars(_loc, 0, 0, src.data(), src.size(), &status);
-+ int need = ucnv_fromUChars(_loc, 0, 0, reinterpret_cast<const UChar*>(src.data()), src.size(), &status);
- if (U_FAILURE(status))
- if (status != U_BUFFER_OVERFLOW_ERROR)
- throw RuntimeException("ucnv_fromUChars failed");
-@@ -112,7 +112,7 @@ void Security::initialize()
- char* shared_library = new char[need+1];
-
- status = U_ZERO_ERROR;
-- ucnv_fromUChars(_loc, shared_library, need+1, src.data(), src.size(), &status);
-+ ucnv_fromUChars(_loc, shared_library, need+1, reinterpret_cast<const UChar*>(src.data()), src.size(), &status);
- if (U_FAILURE(status))
- throw RuntimeException("ucnv_fromUChars failed");
-
diff --git a/dev-libs/beecrypt/files/beecrypt-4.2.1-gcc-4.7.patch b/dev-libs/beecrypt/files/beecrypt-4.2.1-gcc-4.7.patch
deleted file mode 100644
index dff5d8c04ab9..000000000000
--- a/dev-libs/beecrypt/files/beecrypt-4.2.1-gcc-4.7.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/beecrypt/c++/util/AbstractSet.h
-+++ b/include/beecrypt/c++/util/AbstractSet.h
-@@ -56,7 +56,7 @@
- if (c->size() != size())
- return false;
-
-- return containsAll(*c);
-+ return this->containsAll(*c);
- }
- return false;
- }
diff --git a/dev-libs/beecrypt/files/beecrypt-4.2.1-icu-61.patch b/dev-libs/beecrypt/files/beecrypt-4.2.1-icu-61.patch
deleted file mode 100644
index 68845f612d9b..000000000000
--- a/dev-libs/beecrypt/files/beecrypt-4.2.1-icu-61.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-On icu-61 built failures look like:
- include/beecrypt/c++/lang/String.h:76:17:
- error: ‘UnicodeString’ does not name a type
-
-ICU-61 moved all names into icu:: space.
-
-The fix is to add 'using icu::<symbol>'.
-
-Reported-by: Juergen Rose
-Bug: https://bugs.gentoo.org/666542
---- a/c++/beeyond/DHIESParameterSpec.cxx
-+++ b/c++/beeyond/DHIESParameterSpec.cxx
-@@ -36,2 +36,4 @@ using std::auto_ptr;
- #include <unicode/numfmt.h>
-+using icu::RegexPattern;
-+using icu::RegexMatcher;
-
---- a/c++/crypto/Cipher.cxx
-+++ b/c++/crypto/Cipher.cxx
-@@ -30,2 +30,4 @@ using beecrypt::security::Security;
- #include <unicode/ustream.h>
-+using icu::RegexMatcher;
-+using icu::RegexPattern;
-
---- a/c++/lang/Integer.cxx
-+++ b/c++/lang/Integer.cxx
-@@ -29,2 +29,5 @@ using beecrypt::lang::String;
- #include <unicode/numfmt.h>
-+using icu::Formattable;
-+using icu::NumberFormat;
-+
-
---- a/c++/lang/Long.cxx
-+++ b/c++/lang/Long.cxx
-@@ -29,2 +29,4 @@ using beecrypt::lang::String;
- #include <unicode/numfmt.h>
-+using icu::Formattable;
-+using icu::NumberFormat;
-
---- a/c++/util/Date.cxx
-+++ b/c++/util/Date.cxx
-@@ -28,2 +28,3 @@
- #include <unicode/datefmt.h>
-+using icu::DateFormat;
-
---- a/include/beecrypt/c++/lang/String.h
-+++ b/include/beecrypt/c++/lang/String.h
-@@ -41,2 +41,3 @@ using beecrypt::bytearray;
- #include <unicode/unistr.h>
-+using icu::UnicodeString;
-
diff --git a/dev-libs/beecrypt/metadata.xml b/dev-libs/beecrypt/metadata.xml
deleted file mode 100644
index 69ec19c5857b..000000000000
--- a/dev-libs/beecrypt/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">beecrypt</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/arch/arm/package.use.mask b/profiles/arch/arm/package.use.mask
index 690bad1bf16f..852b2407f7e4 100644
--- a/profiles/arch/arm/package.use.mask
+++ b/profiles/arch/arm/package.use.mask
@@ -438,7 +438,6 @@ media-gfx/pstoedit emf
# masking all stable packages with java use flag
net-vpn/openconnect java
dev-util/oprofile java
-dev-libs/beecrypt java
dev-libs/cyrus-sasl java
dev-tex/tex4ht java
dev-vcs/subversion java
diff --git a/profiles/package.mask b/profiles/package.mask
index de9981d6477a..3b3f7d2372b9 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -152,15 +152,6 @@ net-mail/qmail-qfilter
# Removal in 30 days. Bug #684094.
net-proxy/nylon
-# Michał Górny <mgorny@gentoo.org> (19 May 2019)
-# Unmaintained crypto library with last release in 2009. Carries
-# a number of local patches just to build with GCC. Fails tests
-# (#351373), fails to build with clang (#624192). Its last reverse
-# dependency is obsolete version of dev-util/debugedit.
-# Removal in 30 days. Bug #680322.
-dev-libs/beecrypt
-<dev-util/debugedit-4
-
# Hans de Graaff <graaff@gentoo.org> (18 May 2019)
# Old, ruby24-only, slots of ruby packages without any reverse
# dependencies. Use the newer slot version instead.