summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-06 14:54:55 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-06 14:54:55 +0200
commit228683e36e9af43c177da2c037d094917824175f (patch)
treef0a5a1a8b10e25d95764574a5e7b7723bec3ca53
parentapp-admin/awscli: Remove old (diff)
downloadgentoo-228683e3.tar.gz
gentoo-228683e3.tar.bz2
gentoo-228683e3.zip
dev-python/boto3: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest3
-rw-r--r--dev-python/boto3/boto3-1.23.5.ebuild65
-rw-r--r--dev-python/boto3/boto3-1.24.0.ebuild68
-rw-r--r--dev-python/boto3/boto3-1.24.1.ebuild68
4 files changed, 0 insertions, 204 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 28021ed9b947..92fd51e241cd 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,5 +1,2 @@
DIST boto3-1.23.10.gh.tar.gz 504080 BLAKE2B 1840715ec72b10131a430abdb303adf7619fb4dc542cb22acefffe378c96d094eb7d024c068df1df48882a22fc52e3883791da39d0e4fb34abdddad4d78c0ce8 SHA512 88d0abfc990eba2118698c27fe9f556a2b2ef27d0e287c2b3d65a1d485d4be264a5e9ccc02c017c404941c34efdb5f9d480ceb7c5752f99ebf95d3fab184dded
-DIST boto3-1.23.5.tar.gz 501625 BLAKE2B 5a996b4dffd325ea2d6582450b027767ca9845e8096193ef4a8a63ecd61999c67a83cc3b5bc4e77d1f50035188f97003942f1b64293adb36a9cd6e71781b2279 SHA512 5496de026313e9a767f3ba42fe903093ce69777627835a00d75dac4aa966c803a46682b4d766002af793c7e8c95be141cd0d0bbbf27961bd020ac18ef64f5175
-DIST boto3-1.24.0.gh.tar.gz 504647 BLAKE2B 85ff8d83abc9c116de2b54bdfe61239494723bf5214ed6edad380fc15a0a8bde5167125aa2289425395d18c4c459ea7eef1ca9af706b6414302dd23543ff43ab SHA512 6c494557521b0cf2e4d172e4e631c9e10c5d2a1047a592d4fc99566d5bad2c5028b74b8a4bfb090fd289558d2e007d3d038da27d416cdf123e19be96af11f4a3
-DIST boto3-1.24.1.gh.tar.gz 505225 BLAKE2B 4a56053f71b7acccfdeaaa6cd43d94d661c6d2b9e706dfd63d1caac032569797e76ad2564c2dc00e551a0161851eee4f23a91288b64edd593c690fe1b62383a4 SHA512 ba03a9e25920e785eec35b40c166acb45a31ccdb5a235e8a4f18f18365f404b4015ce34f2504f5ebcf52d525e783580361d13831276e23c29516272154e29742
DIST boto3-1.24.2.gh.tar.gz 505904 BLAKE2B e5fe9aa089caaa91aa41554a07ba97da55b04f5cc77be58df10ad4b6b9d3ab8ce22f988f658cb653d9f3890a307ea895c1cd57c30b6729ba12a1ee61f475ba1d SHA512 23b550194805859e37b8f3a7b75390bba500e7043e32930ab1ac46d2fca672472def9f4821e0deadaba6e6010afa05e4385a0f6fe229798250746b079fa27810
diff --git a/dev-python/boto3/boto3-1.23.5.ebuild b/dev-python/boto3/boto3-1.23.5.ebuild
deleted file mode 100644
index 3a49cb334fc4..000000000000
--- a/dev-python/boto3/boto3-1.23.5.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="The AWS SDK for Python"
-HOMEPAGE="
- https://github.com/boto/boto3/
- https://pypi.org/project/boto3/
-"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/boto3"
- inherit git-r3
- BOTOCORE_PV=${PV}
-else
- SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
- # botocore is x.(y+3).z
- BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
-fi
-
-RDEPEND="
- >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
- >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # don't lock versions to narrow ranges
- sed -e '/botocore/ d' \
- -e '/jmespath/ d' \
- -e '/s3transfer/ d' \
- -i setup.py || die
-
- # do not rely on bundled deps in botocore (sic!)
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest tests/{functional,unit} -n "$(makeopts_jobs)"
-}
diff --git a/dev-python/boto3/boto3-1.24.0.ebuild b/dev-python/boto3/boto3-1.24.0.ebuild
deleted file mode 100644
index 6edcc751d54b..000000000000
--- a/dev-python/boto3/boto3-1.24.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="The AWS SDK for Python"
-HOMEPAGE="
- https://github.com/boto/boto3/
- https://pypi.org/project/boto3/
-"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/boto3"
- inherit git-r3
- BOTOCORE_PV=${PV}
-else
- SRC_URI="
- https://github.com/boto/boto3/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- "
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-
- # botocore is x.(y+3).z
- BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
-fi
-
-RDEPEND="
- >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
- >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # don't lock versions to narrow ranges
- sed -e '/botocore/ d' \
- -e '/jmespath/ d' \
- -e '/s3transfer/ d' \
- -i setup.py || die
-
- # do not rely on bundled deps in botocore (sic!)
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest tests/{functional,unit} -n "$(makeopts_jobs)"
-}
diff --git a/dev-python/boto3/boto3-1.24.1.ebuild b/dev-python/boto3/boto3-1.24.1.ebuild
deleted file mode 100644
index 6edcc751d54b..000000000000
--- a/dev-python/boto3/boto3-1.24.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1 multiprocessing
-
-DESCRIPTION="The AWS SDK for Python"
-HOMEPAGE="
- https://github.com/boto/boto3/
- https://pypi.org/project/boto3/
-"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/boto/boto3"
- inherit git-r3
- BOTOCORE_PV=${PV}
-else
- SRC_URI="
- https://github.com/boto/boto3/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- "
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-
- # botocore is x.(y+3).z
- BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
-fi
-
-RDEPEND="
- >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
- >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source \
- 'dev-python/guzzle_sphinx_theme'
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # don't lock versions to narrow ranges
- sed -e '/botocore/ d' \
- -e '/jmespath/ d' \
- -e '/s3transfer/ d' \
- -i setup.py || die
-
- # do not rely on bundled deps in botocore (sic!)
- find -name '*.py' -exec sed -i \
- -e 's:from botocore[.]vendored import:import:' \
- -e 's:from botocore[.]vendored[.]:from :' \
- {} + || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- epytest tests/{functional,unit} -n "$(makeopts_jobs)"
-}