summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-28 15:29:46 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-28 16:51:09 -0500
commit22a0ec91919e272ee0386c068a93c25caeaee9e7 (patch)
tree01e45f0b2dfd591c40981c04a439b9fbcea69ef5
parentdev-python/os-client-config: 1.28.0 bup (diff)
downloadgentoo-22a0ec91.tar.gz
gentoo-22a0ec91.tar.bz2
gentoo-22a0ec91.zip
dev-python/python-glanceclient: 2.8.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--dev-python/python-glanceclient/Manifest1
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-2.8.0.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 32da2f5f1320..b544bc2bfbc9 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,3 +1,4 @@
DIST python-glanceclient-2.0.1.tar.gz 159091 SHA256 77e92a256679ebc76101198482ca34dd0b636f12313c4aa92132b831064b3968 SHA512 48253d70c50ad5b671e0d662612217f76e79b2e15ec1714d578c85ffae3d6b18e019f90946d11cc90e41b981c6bb24c7f47094c046892fdee33034689631af53 WHIRLPOOL 55ba594d226a9dc9bc7d007b7f3bdabed5be084f0c204b93ad604e854ed9db27f180817b8ec0510c06586bcbfc8b7998b20f7777f61ac23fd56550ef08d91abb
DIST python-glanceclient-2.5.0.tar.gz 157864 SHA256 8c510a089fb4dc8355d5db0de608361888b5e4e0c81e0d153ae1b1366bfb8a08 SHA512 1a702666c9430577e4d6018c95df59600bdb644b224708aaedcef3308d6209f9bc60d5f228126554b27e723414703ef7fe20d0c69058882748eb1e59d63afaa2 WHIRLPOOL a96a7b49ffcd280c085669d4c04a73ad9f6023f774cc56db8142ffb3f52fc68ee0a1eeb047aa31731b15b37f70bb5c1de178172097ae704b05d5e66c2e08b16c
DIST python-glanceclient-2.6.0.tar.gz 161852 SHA256 59ce6ec4cb17e6cb5b94e12d4563a1b6fe2f6dd11c8e1d4e42e45073c76bcc0b SHA512 c566a261a42cc38db0adea507bbca4790ffa850a81bbf98ff01aa8629bb2d80fe9717a2e17b048367974809c7f7d348881397a53bfeafbc7438b73f9b4bc97e0 WHIRLPOOL 788eda86f6d6d0a0e23c676356881e24d7eb852724caa475dfbb4f5ab45920706de11f6b88eb76de3eb00d985e32510b4d0f2db6149ce5445b9e8e9131d9827b
+DIST python-glanceclient-2.8.0.tar.gz 177172 SHA256 26795c19d9b5a2ec54dfc023f5ea869f8b8ae772669606b4af9125a2db51a813 SHA512 257eaf1d548a3a6277b9c80e8b23b9ae4231586307c43a064754c227f3e3c872451ec0469aca931638ea0f7c9920892878c677b144dc72bad215c38d375a63d3 WHIRLPOOL 49414676f2de742169a0c4259b7a8626db2956e3dd8088d0aaafb5a5acf2b1e0af9d463ec57a4f400586feb9274292cbaece772a9b19723af87ad781a15b01fb
diff --git a/dev-python/python-glanceclient/python-glanceclient-2.8.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-2.8.0.ebuild
new file mode 100644
index 000000000000..1576b4c1d14f
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-2.8.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+REQUIRED_USE="test? ( doc )"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ dev-python/ordereddict[$(python_gen_usedep 'python2_7')]
+ >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.0.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/keystoneauth-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.0.1[${PYTHON_USEDEP}]
+ !~dev-python/warlock-1.3.0[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 tests && einfo "run flake8 over tests folder passed" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}