summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 07:33:54 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 07:51:58 +0100
commit22a5d5d98572cc8abf44e5779cacd5afb9cede9d (patch)
tree0c714c426506b73dd0e5df183a651de8c8a2a468
parentdev-python/mkdocs-material: Bump to 9.0.12 (diff)
downloadgentoo-22a5d5d9.tar.gz
gentoo-22a5d5d9.tar.bz2
gentoo-22a5d5d9.zip
dev-python/jupyter_console: Bump to 6.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jupyter_console/Manifest1
-rw-r--r--dev-python/jupyter_console/jupyter_console-6.5.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jupyter_console/Manifest b/dev-python/jupyter_console/Manifest
index 7c0214dfb2ab..2398d2c69afd 100644
--- a/dev-python/jupyter_console/Manifest
+++ b/dev-python/jupyter_console/Manifest
@@ -1 +1,2 @@
DIST jupyter_console-6.4.4.tar.gz 35145 BLAKE2B d37190c30eceba79c0d37ad60d88c9e691759aaccb29a64a9482b7c3cf3315efa3c902ac2244c2139ef2f94a77450115124227768f8291f73512796aaff1214a SHA512 1f06591ed2a0fcf56e783d4e9f2a7c3f58a4f566cfb63b3367edac23c7709aa1af7bf6639c7358227a987049804da90658144fa5ad38db120c0816e78ed465ef
+DIST jupyter_console-6.5.0.tar.gz 35609 BLAKE2B 056386eaa1c214b27ff10993d08fc5351ab9f6775fa8f2882bbe8ed6ca4170edb8a8024740f3a9f0f9667c253a1945700da0e9a3bc925d970597b43c830c9e6b SHA512 9c3b44a43d0a18bbcade97fee514859b6c370941e80525630195fb6bf8fb32c3cf048dfabd2c41f7f98365d2fbd87c9e190f9fb8e899c5a29266585766df66af
diff --git a/dev-python/jupyter_console/jupyter_console-6.5.0.ebuild b/dev-python/jupyter_console/jupyter_console-6.5.0.ebuild
new file mode 100644
index 000000000000..98dd00f203e1
--- /dev/null
+++ b/dev-python/jupyter_console/jupyter_console-6.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="https://jupyter.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-3.0.30[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
+"
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest