summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-11-27 14:06:06 +0100
committerPacho Ramos <pacho@gentoo.org>2016-11-27 14:06:06 +0100
commit22b1b0b61de5e73ab2e0876b788b1c28b3f89a06 (patch)
tree760ba3170e1c54ff251c7517131eb7d128d4189e
parentapp-misc/golly: Drop old (diff)
downloadgentoo-22b1b0b6.tar.gz
gentoo-22b1b0b6.tar.bz2
gentoo-22b1b0b6.zip
dev-vcs/rapidsvn: Drop old
Package-Manager: portage-2.3.2
-rw-r--r--dev-vcs/rapidsvn/rapidsvn-0.12.1-r1.ebuild121
-rw-r--r--dev-vcs/rapidsvn/rapidsvn-0.12.1-r2.ebuild126
2 files changed, 0 insertions, 247 deletions
diff --git a/dev-vcs/rapidsvn/rapidsvn-0.12.1-r1.ebuild b/dev-vcs/rapidsvn/rapidsvn-0.12.1-r1.ebuild
deleted file mode 100644
index 8bad8da3b54d..000000000000
--- a/dev-vcs/rapidsvn/rapidsvn-0.12.1-r1.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-WX_GTK_VER=2.8
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils fdo-mime flag-o-matic multilib python-single-r1 versionator wxwidgets
-
-MY_PV=$(get_version_component_range 1-2)
-MY_REL="1"
-
-DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system"
-HOMEPAGE="http://rapidsvn.tigris.org/"
-SRC_URI="
- http://www.rapidsvn.org/download/release/${PV}/${P}.tar.gz
- doc? ( https://dev.gentoo.org/~jlec/distfiles/svncpp.dox.xz )"
-
-LICENSE="GPL-2 LGPL-2.1 FDL-1.2"
-SLOT="0"
-KEYWORDS="amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEP="
- ${PYTHON_DEPS}
- dev-libs/apr
- dev-libs/apr-util
- dev-vcs/subversion
- x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="${COMMON_DEP}
- doc? (
- dev-libs/libxslt
- app-text/docbook-sgml-utils
- app-doc/doxygen
- app-text/docbook-xsl-stylesheets
- media-gfx/graphviz
-)"
-RDEPEND="${COMMON_DEP}"
-
-PATCHES=(
- "${FILESDIR}/${P}-svncpp_link.patch"
- "${FILESDIR}/${P}-locale.patch" )
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-DOCS=( HACKING.txt TRANSLATIONS )
-
-src_prepare() {
- if use doc; then
- mv "${WORKDIR}"/svncpp.dox doc/svncpp/ || die
- fi
- strip-linguas $(grep ^RAPIDSVN_LANGUAGES src/locale/Makefile.am | sed 's:RAPIDSVN_LANGUAGES=::g')
- sed \
- -e "/^RAPIDSVN_LANGUAGES/s:=.*:=${LINGUAS}:g" \
- -i src/locale/Makefile.am || die
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=( --with-wx-config=${WX_CONFIG} )
-
- if use doc; then
- myeconfargs+=( --with-manpage=yes )
- else
- myeconfargs+=(
- --without-xsltproc
- --with-manpage=no
- --without-doxygen
- --without-dot )
- fi
-
- append-cppflags $( apr-1-config --cppflags )
-
- myeconfargs+=(
- --with-svn-lib="${EPREFIX}"/usr/$(get_libdir)
- --with-svn-include="${EPREFIX}"/usr/include
- --with-apr-config="${EPREFIX}/usr/bin/apr-1-config"
- --with-apu-config="${EPREFIX}/usr/bin/apu-1-config"
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- use doc && autotools-utils_src_compile -C doc/manpage manpage
-}
-
-src_install() {
- autotools-utils_src_install
-
- doicon src/res/rapidsvn.ico src/res/bitmaps/${PN}*.png
- make_desktop_entry rapidsvn "RapidSVN ${PV}" \
- "${EPREFIX}/usr/share/pixmaps/rapidsvn_32x32.png" \
- "RevisionControl;Development"
-
- if use doc ; then
- doman doc/manpage/${PN}.1
- dohtml "${S}"/doc/svncpp/html/*
- fi
-}
-
-src_test() {
- pushd "${BUILD_DIR}"/src/tests/svncpp > /dev/null || die
- emake
- ./svncpptest | grep OK || die
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}
diff --git a/dev-vcs/rapidsvn/rapidsvn-0.12.1-r2.ebuild b/dev-vcs/rapidsvn/rapidsvn-0.12.1-r2.ebuild
deleted file mode 100644
index eb3c7fa6bda6..000000000000
--- a/dev-vcs/rapidsvn/rapidsvn-0.12.1-r2.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-WX_GTK_VER=3.0
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils fdo-mime flag-o-matic multilib python-single-r1 versionator wxwidgets
-
-MY_PV=$(get_version_component_range 1-2)
-MY_REL="1"
-
-DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system"
-HOMEPAGE="http://rapidsvn.tigris.org/"
-SRC_URI="
- http://www.rapidsvn.org/download/release/${PV}/${P}.tar.gz
- doc? ( https://dev.gentoo.org/~jlec/distfiles/svncpp.dox.xz )"
-
-LICENSE="GPL-2 LGPL-2.1 FDL-1.2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEP="
- ${PYTHON_DEPS}
- dev-libs/apr
- dev-libs/apr-util
- dev-vcs/subversion
- x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="${COMMON_DEP}
- doc? (
- dev-libs/libxslt
- app-text/docbook-sgml-utils
- app-doc/doxygen
- app-text/docbook-xsl-stylesheets
- media-gfx/graphviz
-)"
-RDEPEND="${COMMON_DEP}"
-
-PATCHES=(
- "${FILESDIR}/${P}-svncpp_link.patch"
- "${FILESDIR}/${P}-locale.patch"
- "${FILESDIR}/${P}-wx3.0.patch" )
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-DOCS=( HACKING.txt TRANSLATIONS )
-
-src_prepare() {
- need-wxwidgets unicode
- if use doc; then
- mv "${WORKDIR}"/svncpp.dox doc/svncpp/ || die
- fi
- strip-linguas $(grep ^RAPIDSVN_LANGUAGES src/locale/Makefile.am | sed 's:RAPIDSVN_LANGUAGES=::g')
- sed \
- -e "/^RAPIDSVN_LANGUAGES/s:=.*:=${LINGUAS}:g" \
- -i src/locale/Makefile.am || die
-
- mv configure.in configure.ac || die
-
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=( --with-wx-config=${WX_CONFIG} )
-
- if use doc; then
- myeconfargs+=( --with-manpage=yes )
- else
- myeconfargs+=(
- --without-xsltproc
- --with-manpage=no
- --without-doxygen
- --without-dot )
- fi
-
- append-cppflags $( apr-1-config --cppflags )
-
- myeconfargs+=(
- --with-svn-lib="${EPREFIX}"/usr/$(get_libdir)
- --with-svn-include="${EPREFIX}"/usr/include
- --with-apr-config="${EPREFIX}/usr/bin/apr-1-config"
- --with-apu-config="${EPREFIX}/usr/bin/apu-1-config"
- )
- autotools-utils_src_configure
-}
-
-src_compile() {
- autotools-utils_src_compile
- use doc && autotools-utils_src_compile -C doc/manpage manpage
-}
-
-src_install() {
- autotools-utils_src_install
-
- doicon src/res/rapidsvn.ico src/res/bitmaps/${PN}*.png
- make_desktop_entry rapidsvn "RapidSVN ${PV}" \
- "${EPREFIX}/usr/share/pixmaps/rapidsvn_32x32.png" \
- "RevisionControl;Development"
-
- if use doc ; then
- doman doc/manpage/${PN}.1
- dohtml "${S}"/doc/svncpp/html/*
- fi
-}
-
-src_test() {
- pushd "${BUILD_DIR}"/src/tests/svncpp > /dev/null || die
- emake
- ./svncpptest | grep OK || die
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}