summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-30 06:45:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-30 07:02:29 +0200
commit22c7eccbd6d21b176e824e31f3ba3f9de551f999 (patch)
treed7f410fdeca132925b2fa9919e0ee45f699179d9
parentperl-core/File-Temp: fix _PC_CHOWN_RESTRICTED (diff)
downloadgentoo-22c7eccbd6d21b176e824e31f3ba3f9de551f999.tar.gz
gentoo-22c7eccbd6d21b176e824e31f3ba3f9de551f999.tar.bz2
gentoo-22c7eccbd6d21b176e824e31f3ba3f9de551f999.zip
dev-python/scikit-build-core: Bump to 0.9.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.9.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index e21f78d1c36a..1aebda6cdcc5 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1 +1,2 @@
DIST scikit_build_core-0.9.2.tar.gz 225078 BLAKE2B 8d50e82754013f23a2216d269757fce5b56c5fa99e2f3b93e3bb65e50730799f2874d0eaa71681e248eeb30c443cde03a5bd447732b764852f2069ed18ea98d3 SHA512 c94cb9b109c994bedaba0e82de15caaf4fc4ae5c08375324aeb60f8d05911cc958a70c0430d35b23ad9792d39ab0312ff607b0587cd55eb4fe68ae4f28eed1d9
+DIST scikit_build_core-0.9.3.tar.gz 226732 BLAKE2B b15985eb4bf9cd44e75cf3ea1db4a1541dbac2310927608ab1ec31d5015ef4433290894755230ff5d691d69d90bce1ac92966209e46091d7f4d76099f33cca0a SHA512 e25adbcd2037471046376d3877d7a4a5bea42f3f9c13beaec646ed6e7a254138d0fce050309f634b61ec75c83ad76e34ebfa0bfa403ae394c25870cf15e0ff7a
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.9.3.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.9.3.ebuild
new file mode 100644
index 000000000000..5241d6b57db5
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.9.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ app-alternatives/ninja
+ dev-build/cmake
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.2[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local _EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ # setuptools now respects PEP 625
+ tests/test_setuptools_pep517.py::test_pep517_sdist
+ )
+ local EPYTEST_IGNORE=(
+ # needs unpackaged validate_pyproject
+ tests/test_schema.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p subprocess -m "not isolated and not network"
+}