summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-01-08 22:07:08 +0100
committerSebastian Pipping <sping@gentoo.org>2023-01-08 22:07:56 +0100
commit22cd904362c30ddaa479349fdc3b8278eb8c3aac (patch)
treef2a4638ca7b20c6c5b2a17c44c46bff26e5cf38e
parentdev-libs/libwbxml: drop 0.11.7, 0.11.7-r1 (diff)
downloadgentoo-22cd904362c30ddaa479349fdc3b8278eb8c3aac.tar.gz
gentoo-22cd904362c30ddaa479349fdc3b8278eb8c3aac.tar.bz2
gentoo-22cd904362c30ddaa479349fdc3b8278eb8c3aac.zip
media-plugins/ladspa-bs2b: Fix compilation for dash /bin/sh
Closes: https://bugs.gentoo.org/889426 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--media-plugins/ladspa-bs2b/ladspa-bs2b-0.9.1-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/ladspa-bs2b/ladspa-bs2b-0.9.1-r3.ebuild b/media-plugins/ladspa-bs2b/ladspa-bs2b-0.9.1-r3.ebuild
new file mode 100644
index 000000000000..fe0ab13e4dab
--- /dev/null
+++ b/media-plugins/ladspa-bs2b/ladspa-bs2b-0.9.1-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools
+
+DESCRIPTION="LADSPA plugin for bs2b headphone filter"
+HOMEPAGE="http://bs2b.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bs2b/plugins/LADSPA%20plugin/${PV}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/ladspa-sdk
+ >=media-libs/libbs2b-3.1.0"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed 's,dist-lzma,,' -i configure.ac || die
+ eautoreconf # bug 889426
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}