summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-07 16:57:57 +0000
committerSam James <sam@gentoo.org>2023-03-07 16:58:20 +0000
commit22cecdc3bf96930e5f433b7219e0db338fd7a43a (patch)
tree33d1547307cc80a41a8b053bf118c2449ce4ceda
parentapp-mobilephone/gammu: fix runtime w/ FORTIFY_SOURCE=3 (diff)
downloadgentoo-22cecdc3bf96930e5f433b7219e0db338fd7a43a.tar.gz
gentoo-22cecdc3bf96930e5f433b7219e0db338fd7a43a.tar.bz2
gentoo-22cecdc3bf96930e5f433b7219e0db338fd7a43a.zip
dev-python/mpmath: add 1.3.0
Bug: https://bugs.gentoo.org/900202 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/mpmath/Manifest1
-rw-r--r--dev-python/mpmath/mpmath-1.3.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/mpmath/Manifest b/dev-python/mpmath/Manifest
index b9377f33da42..f77e408f7301 100644
--- a/dev-python/mpmath/Manifest
+++ b/dev-python/mpmath/Manifest
@@ -1 +1,2 @@
DIST mpmath-1.2.1.tar.gz 2135690 BLAKE2B a21e0ef04a025f23e32dad5839db411708266c6cf3408e97ec5c995f197b14f446c1d328bd2e9f50e1c48a2e08239ef7908fcc3aab8659118fc1e0e78106a47e SHA512 2dd908bca26162adcdce0493146d009e04d3d96db965ff2207c332504020fa6f5a5e2af97d38e8fb3e7442a26c1e93a756a8d93b378da720ab7c07753f700d10
+DIST mpmath-1.3.0.tar.gz 2136844 BLAKE2B 42b121896e1bcffe459ac5591a4e0ec41fdd708d5518b1a76bf4cc434f34e5801d77207ea9769d11b6746340aa32a84b58e089c81b5163b48a80ccc6ecd0a345 SHA512 ec703e661323035e3c973fc2e52206e793f6182ed9897e5a483cb35a22421d7869df850cdd89fc1ef4e1bb28b17b4914447116dbeed136a687e582cce0bf9e42
diff --git a/dev-python/mpmath/mpmath-1.3.0.ebuild b/dev-python/mpmath/mpmath-1.3.0.ebuild
new file mode 100644
index 000000000000..ddc293e2387e
--- /dev/null
+++ b/dev-python/mpmath/mpmath-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python library for arbitrary-precision floating-point arithmetic"
+HOMEPAGE="https://mpmath.org/"
+SRC_URI="https://github.com/fredrik-johansson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="gmp matplotlib"
+
+RDEPEND="
+ gmp? ( dev-python/gmpy[${PYTHON_USEDEP}] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" mpmath/tests/runtests.py -local || die "Tests failed with ${EPYTHON}"
+}