summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-21 06:28:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-21 06:28:19 +0200
commit22ea161b0cebb6219bf41fbbb8559374b8c47ff5 (patch)
tree759d4abfdfdc1ef858a8b72b15659873776f4f26
parentxfce-extra/xfce4-mailwatch-plugin: Bump to 1.3.1 (diff)
downloadgentoo-22ea161b0cebb6219bf41fbbb8559374b8c47ff5.tar.gz
gentoo-22ea161b0cebb6219bf41fbbb8559374b8c47ff5.tar.bz2
gentoo-22ea161b0cebb6219bf41fbbb8559374b8c47ff5.zip
xfce-base/libxfce4ui: Bump to 4.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.19.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 261e09838864..d1729f8469f4 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,3 +1,4 @@
DIST libxfce4ui-4.18.2.tar.bz2 901949 BLAKE2B 17bf0541646735ec54da5f322d858896fa2fd132fe93864372a67d4936b4467def749f4a0dd4f3d23ecb7a2b3843367f88ccf74b7e040e7ad6f6c15fec45055f SHA512 758466e2e3096791b99e1a00c9f499d95327581ad336fc1ab0d51e3d150206d522f44c2e6053b0032499dd0cb337510cf6940dc77499cef3ecbb484de7787457
DIST libxfce4ui-4.18.3.tar.bz2 905070 BLAKE2B 0ed4bdaa1135d22d5155e22d8ecaaca2b2be714a097f26fc0388ea4bfdf39d8bf854e85ee1ace590000000d81034e414a7a0782ba3218e09901a1e0afdaf5fbe SHA512 697d883352189426b36d6c06254404b1dd2ba5f9630691b7dfddb2496d7b0233e807485155ead02dfaa73dc543eee7d8e459dc72ec56f646ec020fc9142edd28
DIST libxfce4ui-4.19.0.tar.bz2 1165579 BLAKE2B cac5272525f29050c680e241d15ce8b66360559a627031e0313c0e79f9c8a424bc8972135a20c2a1aeea3446ae21425da140a7c3b9739402ca368c7ecd1aa2a2 SHA512 038ce1787f5fc99d41e92a316e1e2029b4cc44f325e1eae09eb146fcc1332bc6f39607fe1f2854da9fa1c9573b102d3bd96b2bc9d08c5178bb5c738fd9aef97c
+DIST libxfce4ui-4.19.1.tar.bz2 1165274 BLAKE2B a72fbeb991063876c4aca5d25648a37e565a7842ea400e7b997684ec71c04dfa559675fa7e5023a30f9c50bed10fd458ddd2c68f3a06ee1e119e0dd8ed0a5c34 SHA512 a3ea0767319f9de832de301704e19e0881aa960e922e516caf11cc1dd9b20938b2acc716c3bbc9aa0f335ca26d44356047cdc63a158fd138856660c6dda013c1
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.19.1.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.19.1.ebuild
new file mode 100644
index 000000000000..e1566e7f25a4
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.19.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4ui/start
+ https://gitlab.xfce.org/xfce/libxfce4ui/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="glade +introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3[introspection?,X]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}