summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 15:54:33 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 15:54:33 +0100
commit22fb95c898532c67173215eb2cb716b131346797 (patch)
treec86e39b8612bf8ad8024e3446a74934a6c7e9a19
parentdev-python/eradicate: Switch to PEP 517 build (diff)
downloadgentoo-22fb95c8.tar.gz
gentoo-22fb95c8.tar.bz2
gentoo-22fb95c8.zip
dev-python/httpauth: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/httpauth/httpauth-0.3-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/httpauth/httpauth-0.3-r1.ebuild b/dev-python/httpauth/httpauth-0.3-r1.ebuild
new file mode 100644
index 000000000000..703fdd988ecb
--- /dev/null
+++ b/dev-python/httpauth/httpauth-0.3-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI middleware that secures routes using HTTP Digest Authentication"
+HOMEPAGE="https://github.com/jonashaag/httpauth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests nose