summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-04 01:38:54 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-04 02:03:30 +0100
commit22fe17089f20027554c2fe530a9d71f193ea2e42 (patch)
tree90bc1731db6bc4c968ef23aa65d5d3a29cc31f76
parentdev-util/wasm3: filter lto and strict-aliasing (diff)
downloadgentoo-22fe17089f20027554c2fe530a9d71f193ea2e42.tar.gz
gentoo-22fe17089f20027554c2fe530a9d71f193ea2e42.tar.bz2
gentoo-22fe17089f20027554c2fe530a9d71f193ea2e42.zip
games-emulation/ppsspp: filter lto
Closes: https://bugs.gentoo.org/926079 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-emulation/ppsspp/ppsspp-1.15.4.ebuild5
-rw-r--r--games-emulation/ppsspp/ppsspp-1.17.1-r1.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/games-emulation/ppsspp/ppsspp-1.15.4.ebuild b/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
index 17b358731669..064e56772306 100644
--- a/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.15.4.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit python-any-r1 xdg cmake
+inherit flag-o-matic python-any-r1 xdg cmake
DESCRIPTION="A PSP emulator written in C++"
HOMEPAGE="https://www.ppsspp.org/
@@ -51,6 +51,9 @@ pkg_setup() {
}
src_configure() {
+ # bug https://bugs.gentoo.org/926079
+ filter-lto
+
local -a mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
-DCMAKE_SKIP_RPATH=ON
diff --git a/games-emulation/ppsspp/ppsspp-1.17.1-r1.ebuild b/games-emulation/ppsspp/ppsspp-1.17.1-r1.ebuild
index ea035438b7b6..df6bd1ad60c2 100644
--- a/games-emulation/ppsspp/ppsspp-1.17.1-r1.ebuild
+++ b/games-emulation/ppsspp/ppsspp-1.17.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit python-any-r1 xdg cmake
+inherit flag-o-matic python-any-r1 xdg cmake
DESCRIPTION="A PSP emulator written in C++"
HOMEPAGE="https://www.ppsspp.org/
@@ -66,6 +66,9 @@ pkg_setup() {
}
src_configure() {
+ # bug https://bugs.gentoo.org/926079
+ filter-lto
+
local -a mycmakeargs=(
-DBUILD_SHARED_LIBS=OFF
-DCMAKE_SKIP_RPATH=ON