summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2018-01-31 16:57:15 -0800
committerMichał Górny <mgorny@gentoo.org>2018-02-07 21:14:18 +0100
commit230371b00dc1988a33ae7ce3c7841c28bcd32970 (patch)
tree12e0c37b78b5f75714aa6425232167e2f3d483c6
parentdev-go/twofactor: new package (diff)
downloadgentoo-230371b0.tar.gz
gentoo-230371b0.tar.bz2
gentoo-230371b0.zip
dev-go/zglob: new package
dependency of www-plugins/browserpass
-rw-r--r--dev-go/zglob/Manifest1
-rw-r--r--dev-go/zglob/metadata.xml12
-rw-r--r--dev-go/zglob/zglob-0_p20171230.ebuild35
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-go/zglob/Manifest b/dev-go/zglob/Manifest
new file mode 100644
index 000000000000..6d88855ead29
--- /dev/null
+++ b/dev-go/zglob/Manifest
@@ -0,0 +1 @@
+DIST zglob-0_p20171230.tar.gz 7993 BLAKE2B dd441531a30f6491c5c85b82e364bf8a21adb9d3842793ef2d9afc617ab5a7b7f6d83e53bb911bfe0a8205f5a434aaee42f2ab7160cce103f0e83cc198757fa7 SHA512 6eec0222ee27527b992809f235b6e06d24e857866f969f25901eaf21c9a352d6f50ec3ef2874d51cc7b91015bc9c6f197e79445e2c36ed1facad4ec04e919d83
diff --git a/dev-go/zglob/metadata.xml b/dev-go/zglob/metadata.xml
new file mode 100644
index 000000000000..004ae50f4a5f
--- /dev/null
+++ b/dev-go/zglob/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" >
+ <email>lluixhi@gmail.com</email>
+ <name>Aric Belsito</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-go/zglob/zglob-0_p20171230.ebuild b/dev-go/zglob/zglob-0_p20171230.ebuild
new file mode 100644
index 000000000000..2d0bf65d5587
--- /dev/null
+++ b/dev-go/zglob/zglob-0_p20171230.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/mattn/go-zglob
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT=4959821b481786922ac53e7ef25c61ae19fb7c36
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Unix-optimized file globbing and directory walking for Go"
+HOMEPAGE="https://github.com/mattn/go-zglob"
+LICENSE="MIT"
+SLOT="0/${PVR}"
+RDEPEND=""
+
+src_compile() {
+ EGO_PN="${EGO_PN}/cmd/zglob" golang-build_src_compile
+}
+
+src_install() {
+ dobin zglob
+
+ golang-build_src_install
+
+ pushd "src/${EGO_PN}" >/dev/null || die
+ einstalldocs
+ popd >/dev/null || die
+}