summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-09-04 12:53:58 -0400
committerAnthony G. Basile <blueness@gentoo.org>2020-09-04 12:53:58 -0400
commit23058752eea10ee29d2eba26511af922ba296d6b (patch)
treeea73772371d64c53d4e3d2addb5c256506906784
parentsys-libs/uclibc-ng: version bump to 1.0.35 (diff)
downloadgentoo-23058752.tar.gz
gentoo-23058752.tar.bz2
gentoo-23058752.zip
sys-apps/paxctld: version bump to 1.2.5
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--sys-apps/paxctld/Manifest1
-rw-r--r--sys-apps/paxctld/paxctld-1.2.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/paxctld/Manifest b/sys-apps/paxctld/Manifest
index 191a0d21fd1d..f431afd76e08 100644
--- a/sys-apps/paxctld/Manifest
+++ b/sys-apps/paxctld/Manifest
@@ -1 +1,2 @@
DIST paxctld_1.2.3.orig.tar.gz 17174 BLAKE2B 6f288b039f719febf2f3370a0d245c07928f441754f0ac43bb3608d2718548d0ab90fbf9244d5b97bdfbc7c6bfab3d7359d435e99a2e19dd80661019ba0b654c SHA512 da3f5739aabbe0f276a194c71c20349b0571472aa6c114fe46ea4eb406fe1b419b167207b8d0b288776574c455f005386303b8ef92b0294e98532b269017ab54
+DIST paxctld_1.2.5.orig.tar.gz 18694 BLAKE2B 9d219846bbdfc5d709d9fb3758ec9451bef1545d6bb25263aef1c42f992f4201e2ce9f9cae0a77ed7584ec5c3c6dd0e3d0c58ec251a52f0b855c87b0fcf0e826 SHA512 c38b2cb0bf07d0075fa01f95d82adf6aae6e7bd010fa31b349af7c92b0498bf3225344500ef306bb633caec0b642771f453a8445cadbf342775931495d0ef2c2
diff --git a/sys-apps/paxctld/paxctld-1.2.5.ebuild b/sys-apps/paxctld/paxctld-1.2.5.ebuild
new file mode 100644
index 000000000000..c4650263e8b3
--- /dev/null
+++ b/sys-apps/paxctld/paxctld-1.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit systemd
+
+DESCRIPTION="PaX flags maintenance daemon"
+HOMEPAGE="https://www.grsecurity.net/"
+SRC_URI="https://www.grsecurity.net/${PN}/${PN}_${PV}.orig.tar.gz
+ https://dev.gentoo.org/~blueness/hardened-sources/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ # Respect Gentoo flags and don't strip
+ sed -i \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/d' \
+ -e '/^LDFLAGS/d' \
+ -e '/STRIP/d' \
+ Makefile
+
+ eapply_user
+}
+
+src_install() {
+ default
+
+ systemd_dounit "${S}"/rpm/${PN}.service
+}