summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-12-03 13:01:45 -0600
committerFlorian Schmaus <flow@gentoo.org>2023-12-13 08:58:43 +0100
commit23150652fb9df7f283eb8cb7be52239f3c402cd1 (patch)
treed540e387144d7cfdf687defcf421f7b17272af1c
parentnet-irc/weechat: add 4.0.7 (diff)
downloadgentoo-23150652fb9df7f283eb8cb7be52239f3c402cd1.tar.gz
gentoo-23150652fb9df7f283eb8cb7be52239f3c402cd1.tar.bz2
gentoo-23150652fb9df7f283eb8cb7be52239f3c402cd1.zip
net-irc/weechat: add 4.1.2
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Closes: https://github.com/gentoo/gentoo/pull/34107 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--net-irc/weechat/Manifest2
-rw-r--r--net-irc/weechat/weechat-4.1.2.ebuild187
2 files changed, 189 insertions, 0 deletions
diff --git a/net-irc/weechat/Manifest b/net-irc/weechat/Manifest
index ffc22b32bc4b..2afafed90d80 100644
--- a/net-irc/weechat/Manifest
+++ b/net-irc/weechat/Manifest
@@ -12,3 +12,5 @@ DIST weechat-4.1.0.tar.xz 2634500 BLAKE2B 966569916e1274660348b0076143b8e70f6522
DIST weechat-4.1.0.tar.xz.asc 833 BLAKE2B 93882ecfebd931ef390ec027b385bd610734b3d49a634d61e1bb4dfdbfd44b8fecadcb4d20eea0ba5e7643dedb5d29678c53249297e8f9540e033f5106c75cc6 SHA512 982ce28123721db23a22e15c1f31266f81e9e5917a0f0566b98e54dd27487550b61954ebcc2aedb257aec6a1cce9489485f540f4606d2966f18dfa13f3013568
DIST weechat-4.1.1.tar.xz 2634896 BLAKE2B 5a2d5042de0871eabf65b71e1172f891044692cf468aab6fe99f6b6b188826f9a6c227fe7140948907d0b76a5001d644e8efc8a6ac8490b961af12d777f5a29a SHA512 9d6bae5cc0c11cf3d06b0f9e457d01e76d240e8737e683a5c8a1bc89a1102b5ba75b2c59629df9433ba6a5ed42152d4390713618e646089acb7947000d9872d5
DIST weechat-4.1.1.tar.xz.asc 833 BLAKE2B 79d9e304ebea2d2c646acea505b73ec4b0e4e742b1fefe7a44d9f0f05ea2c6ad20a9d6a1468fc4c544e0239494bdec93d1a79fd19c09779845aff612e52c2e82 SHA512 178f134e5ab4948dd8dfd05532216cdc25783970775b28d2499429140f95f8b6ef522dea256d45ed1b282cbb2d0a1d88114e907a28011a3473a5a7c3e2c380af
+DIST weechat-4.1.2.tar.xz 2635776 BLAKE2B cd11602b74c65ae4ed129c3604afc1eff154494ef239ead1cbcf2e9e54fba5c53b292c52b11887c48e3587dca3ab5b42073af77623087a2d185c9540368a63ab SHA512 9df8b43a7210f06cece1d28fcf8559885a0d5590b5691f63205b215417f132e4d74f4af18b572daae2679d5cf574b61538a7067e03087be10e831fee4f55e115
+DIST weechat-4.1.2.tar.xz.asc 833 BLAKE2B 94d700e074393c4bde8b68bacfe4a37d022f82bbd9697b12a1cf1e98cbb15a4295689c704ce8eaaf095ca96c4eea8c63275232a5ca6f40ab09d534fff24e76c5 SHA512 44cc5be0700b7979c85e44a1037fd467a6a920f22dc831fd3263fe6d8967eda001d09126b33adaed385c4082e33b8849cba3dbec48f4900e50e10f4da32a6edd
diff --git a/net-irc/weechat/weechat-4.1.2.ebuild b/net-irc/weechat/weechat-4.1.2.ebuild
new file mode 100644
index 000000000000..4e2ec42c58f6
--- /dev/null
+++ b/net-irc/weechat/weechat-4.1.2.ebuild
@@ -0,0 +1,187 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} )
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake lua-single python-single-r1 xdg
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/weechat/weechat.git"
+else
+ inherit verify-sig
+ SRC_URI="https://weechat.org/files/src/${P}.tar.xz
+ verify-sig? ( https://weechat.org/files/src/${P}.tar.xz.asc )"
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/weechat.org.asc
+ BDEPEND+="verify-sig? ( sec-keys/openpgp-keys-weechat )"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Portable and multi-interface IRC client"
+HOMEPAGE="https://weechat.org/"
+
+LICENSE="GPL-3+"
+SLOT="0/${PV}"
+
+NETWORKS="+irc"
+PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spell +trigger +typing +xfer"
+# dev-lang/v8 was dropped from Gentoo so we can't enable javascript support
+# dev-lang/php eclass support is lacking, php plugins don't work. bug #705702
+SCRIPT_LANGS="guile lua +perl +python ruby tcl"
+LANGS=" cs de es fr it ja pl ru"
+IUSE="doc enchant man nls selinux test +zstd ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
+
+REQUIRED_USE="
+ enchant? ( spell )
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( nls )
+"
+
+RDEPEND="
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls:=
+ sys-libs/ncurses:0=
+ sys-libs/zlib:=
+ net-misc/curl[ssl]
+ charset? ( virtual/libiconv )
+ guile? ( >=dev-scheme/guile-2.0:12= )
+ lua? ( ${LUA_DEPS} )
+ nls? ( virtual/libintl )
+ perl? (
+ dev-lang/perl:=
+ virtual/libcrypt:=
+ )
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ || (
+ dev-lang/ruby:3.2
+ dev-lang/ruby:3.1
+ )
+ )
+ selinux? ( sec-policy/selinux-irc )
+ spell? (
+ enchant? ( app-text/enchant:* )
+ !enchant? ( app-text/aspell )
+ )
+ tcl? ( >=dev-lang/tcl-8.4.15:0= )
+ zstd? ( app-arch/zstd:= )
+"
+
+DEPEND="${RDEPEND}
+ test? ( dev-util/cpputest )
+"
+
+BDEPEND+="
+ virtual/pkgconfig
+ doc? ( >=dev-ruby/asciidoctor-1.5.4 )
+ man? ( >=dev-ruby/asciidoctor-1.5.4 )
+ nls? ( >=sys-devel/gettext-0.15 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3-cmake_lua_version.patch
+)
+
+DOCS="AUTHORS.adoc ChangeLog.adoc Contributing.adoc ReleaseNotes.adoc README.adoc"
+
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ # install only required translations
+ local i
+ for i in ${LANGS} ; do
+ if ! has ${i} ${LINGUAS-${i}} ; then
+ sed -i \
+ -e "/${i}.po/d" \
+ po/CMakeLists.txt || die
+ fi
+ done
+
+ # install only required documentation ; en always
+ local j
+ for i in $(grep -e 'set(.*en.*)$' doc/CMakeLists.txt \
+ | sed -e 's/.*set(\(\w\+\).*/\1/'); do
+ for j in $(grep set.${i} doc/CMakeLists.txt \
+ | sed -e "s/.*${i}\(.*\)).*/\1/" -e 's/ en//'); do
+ if ! has ${j} ${LINGUAS-${j}} ; then
+ sed -i \
+ -e "s/\(set(${i}.*\) ${j}/\1/" \
+ doc/CMakeLists.txt || die
+ fi
+ done
+ done
+
+ # install docs in correct directory
+ sed -i "s#\${DATAROOTDIR}/doc/\${PROJECT_NAME}#\0-${PVR}/html#" doc/CMakeLists.txt || die
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ # fix linking error on Darwin
+ sed -i "s/+ get_config_var('LINKFORSHARED')//" \
+ cmake/FindPython.cmake || die
+ # allow to find the plugins by default
+ sed -i 's/".so,.dll"/".bundle,.so,.dll"/' \
+ src/core/wee-config.c || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIBDIR="${EPREFIX}/usr/$(get_libdir)"
+ -DENABLE_JAVASCRIPT=OFF
+ -DENABLE_LARGEFILE=ON
+ -DENABLE_NCURSES=ON
+ -DENABLE_PHP=OFF
+ -DENABLE_ALIAS=$(usex alias)
+ -DENABLE_BUFLIST=$(usex buflist)
+ -DENABLE_CHARSET=$(usex charset)
+ # -DENABLE_DOC requires all plugins (except javascript).
+ # https://github.com/weechat/weechat/blob/v4.0.2/CMakeLists.txt#L144
+ # Impossible since php was dropped in net-irc/weechat-3.5.r1.ebuild. bug #705702
+ -DENABLE_DOC=OFF
+ -DENABLE_DOC_INCOMPLETE=$(usex doc)
+ -DENABLE_ENCHANT=$(usex enchant)
+ -DENABLE_EXEC=$(usex exec)
+ -DENABLE_FIFO=$(usex fifo)
+ -DENABLE_FSET=$(usex fset)
+ -DENABLE_GUILE=$(usex guile)
+ -DENABLE_IRC=$(usex irc)
+ -DENABLE_LOGGER=$(usex logger)
+ -DENABLE_LUA=$(usex lua)
+ -DENABLE_MAN=$(usex man)
+ -DENABLE_NLS=$(usex nls)
+ -DENABLE_PERL=$(usex perl)
+ -DENABLE_PYTHON=$(usex python)
+ -DENABLE_RELAY=$(usex relay)
+ -DENABLE_RUBY=$(usex ruby)
+ -DENABLE_SCRIPT=$(usex scripts)
+ -DENABLE_SCRIPTS=$(usex scripts)
+ -DENABLE_SPELL=$(usex spell)
+ -DENABLE_TCL=$(usex tcl)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_TRIGGER=$(usex trigger)
+ -DENABLE_TYPING=$(usex typing)
+ -DENABLE_XFER=$(usex xfer)
+ -DENABLE_ZSTD=$(usex zstd)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ if $(locale -a | grep -iq "en_US\.utf.*8"); then
+ cmake_src_test -V
+ else
+ eerror "en_US.UTF-8 locale is required to run ${PN}'s ${FUNCNAME}"
+ die "required locale missing"
+ fi
+}