summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-20 13:25:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-20 13:30:36 +0200
commit23153065eb02055e3326e3f3257dcab5bc2553df (patch)
tree6918743d2722bd8da83975d95cdd74c53f6bb0c3
parentgames-util/lutris: drop 0.5.13-r2 (diff)
downloadgentoo-23153065eb02055e3326e3f3257dcab5bc2553df.tar.gz
gentoo-23153065eb02055e3326e3f3257dcab5bc2553df.tar.bz2
gentoo-23153065eb02055e3326e3f3257dcab5bc2553df.zip
net-misc/smb4k: add 3.2.4
Upstream changelog: - Fix the reported paths of the synchronization progress information: Use the relative path returned by rsync and emit the correct paths with the description() signal. - In the 'Authentication' configuration page, fix the missing connection of the reset button to its slot. - In the 'Authentication' configuration page, fix the wrong parent for the button box. This got previously mended by adding the button box to the editor's layout, but we should fix it anyway. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-misc/smb4k/Manifest1
-rw-r--r--net-misc/smb4k/smb4k-3.2.4.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/smb4k/Manifest b/net-misc/smb4k/Manifest
index 6b0d375ed93c..90b785000109 100644
--- a/net-misc/smb4k/Manifest
+++ b/net-misc/smb4k/Manifest
@@ -1 +1,2 @@
DIST smb4k-3.2.3.tar.xz 4314676 BLAKE2B f345e7c57e0f96eecf38aebddc2808cee2d38106bce66083bb0abbd7630b75cb7c1266f64c066d6e9884ecc778c11a95336df50cca74534ea28e2d5b997ad9bb SHA512 ff91ba307aa8934bdee045aad5963440d80794ad6405b1770072fda590f658db20d096f8e98de3a38cebe0fedf6cf86cbe7aed4f8521aa0f13fa496d91f7d2b2
+DIST smb4k-3.2.4.tar.xz 4314512 BLAKE2B 48af157db0196e2c59723f51f5ca3c26d74ba7b11e9b6638be2618679904bd50123670519b69d4410583ab8a78af8941ced9b23ab8ca37a526d22e5e4e4fa758 SHA512 2eb9ffc320d5b53a23cda1a2d20394106835521b3fa84a399763857c03db1177455ba5d03a66d8da9655ee0d1b970275f5f851ca3671f51c44281d4817f5e39b
diff --git a/net-misc/smb4k/smb4k-3.2.4.ebuild b/net-misc/smb4k/smb4k-3.2.4.ebuild
new file mode 100644
index 000000000000..d52805fd7b61
--- /dev/null
+++ b/net-misc/smb4k/smb4k-3.2.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=5.82.0
+QTMIN=5.15.5
+inherit ecm kde.org
+
+DESCRIPTION="Advanced network neighborhood browser"
+HOMEPAGE="https://apps.kde.org/smb4k/
+https://sourceforge.net/p/smb4k/home/Home/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="5"
+IUSE="+discovery plasma"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdnssd-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ net-fs/samba[cups]
+ discovery? (
+ net-libs/kdsoap:=
+ net-libs/kdsoap-ws-discovery-client
+ )
+"
+RDEPEND="${DEPEND}
+ plasma? (
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSMB4K_WITH_WS_DISCOVERY=$(usex discovery)
+ -DSMB4K_INSTALL_PLASMOID=$(usex plasma)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "Users of Samba 4.7 and above please note that for the time being,"
+ elog "the following setting has to be added to or changed in the [global]"
+ elog "section of the smb.conf file:"
+ elog
+ elog "[global]"
+ elog "client max protocol = NT1"
+}