summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-05-05 06:33:55 +0200
committerMichael Weber <xmw@gentoo.org>2017-05-05 06:33:55 +0200
commit231890aa0d85e4012660ddd6822bb24a0847fe00 (patch)
tree09a618dbe2316944db11a35692c9297424c032d9
parentsys-auth/ykpers: Add DEPEND on asciidoc since it is needed for build (diff)
downloadgentoo-231890aa.tar.gz
gentoo-231890aa.tar.bz2
gentoo-231890aa.zip
media-gfx/printrun: Version bump (bug 616420).
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--media-gfx/printrun/Manifest1
-rw-r--r--media-gfx/printrun/printrun-20150310.ebuild26
-rw-r--r--media-gfx/printrun/printrun-9999.ebuild24
3 files changed, 51 insertions, 0 deletions
diff --git a/media-gfx/printrun/Manifest b/media-gfx/printrun/Manifest
index e95b22629137..c5da39cf85cc 100644
--- a/media-gfx/printrun/Manifest
+++ b/media-gfx/printrun/Manifest
@@ -1 +1,2 @@
DIST printrun-20140730.tar.gz 902029 SHA256 3412882627a82bba0fcd0cdf7639074085d3355e5aef48ccdc91687b027a24fa SHA512 c60d3db1a9255a56aad30a8290e18707cc34774af8cc52be042a3fabe653a64874485a153763886458cb45fff718ba134642e530a9d065fcc42ae0473ee17da8 WHIRLPOOL 1f8c91e867a375df998248d31bda0c5901d1ba52071aee12acea42a53b44393332a86562ea96c58801bde63a961d4af14b05f4defc45cfe1f41061a4ee9438e1
+DIST printrun-20150310.tar.gz 906153 SHA256 6edaa533df5a590f55039b81e47f61881d2a47de07c3391d53bfb6d847f46d2e SHA512 359a4a6128b274a6709fb5c35a2d6c510bb57e010cfb12ddefa39cdb371f2141e2cab394be7d9d2f1dbc0175cc24deba61941d73b6c19fb299083afbf1141f1e WHIRLPOOL 38d3ead2be8fb7f802d73956bda5e83c99a902c2682f5c48f74d92e8c5e30b351b06821d6178d3b44722a10982d7a79c471fb3a27d2f313bfb647e9a241e92e1
diff --git a/media-gfx/printrun/printrun-20150310.ebuild b/media-gfx/printrun/printrun-20150310.ebuild
new file mode 100644
index 000000000000..5bf664f6aee5
--- /dev/null
+++ b/media-gfx/printrun/printrun-20150310.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="GUI interface for 3D printing on RepRap and other printers"
+HOMEPAGE="https://github.com/kliment/Printrun"
+SRC_URI="https://github.com/kliment/Printrun/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pyserial
+ dev-python/wxpython:2.8
+ dev-python/pyglet
+ dev-python/dbus-python
+ media-gfx/cairosvg"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Printrun-${P}"
diff --git a/media-gfx/printrun/printrun-9999.ebuild b/media-gfx/printrun/printrun-9999.ebuild
new file mode 100644
index 000000000000..a8367bb5868c
--- /dev/null
+++ b/media-gfx/printrun/printrun-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="GUI interface for 3D printing on RepRap and other printers"
+HOMEPAGE="https://github.com/kliment/Printrun"
+EGIT_REPO_URI="https://github.com/kliment/Printrun.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="dev-python/pyserial
+ dev-python/wxpython:2.8
+ dev-python/pyglet
+ dev-python/dbus-python
+ media-gfx/cairosvg"
+RDEPEND="${DEPEND}"