summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-03-03 22:32:56 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-03-03 23:38:33 +0100
commit232ad96fbe44a9d02a022fba1e09b407a6eba790 (patch)
tree7d473bb76bf10cfae4043d178584587206574321
parentgames-emulation/ppsspp: pin dev-util/glslang to slot 0/1 (diff)
downloadgentoo-232ad96f.tar.gz
gentoo-232ad96f.tar.bz2
gentoo-232ad96f.zip
dev-libs/cglm: restore doc build (was in guru overlay)
Also remove now useless "-Dwerror=false" Closes: https://bugs.gentoo.org/897714 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--dev-libs/cglm/cglm-0.8.9-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/cglm/cglm-0.8.9-r1.ebuild b/dev-libs/cglm/cglm-0.8.9-r1.ebuild
new file mode 100644
index 000000000000..8adee7688d32
--- /dev/null
+++ b/dev-libs/cglm/cglm-0.8.9-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="sphinx"
+DOCS_AUTODOC=1
+DOCS_DEPEND="dev-python/sphinx-rtd-theme"
+DOCS_DIR="${S}/docs/source"
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit python-any-r1 docs meson
+
+DESCRIPTION="OpenGL Mathematics (glm) for C"
+HOMEPAGE="https://github.com/recp/cglm"
+SRC_URI="https://github.com/recp/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ # DOCS_DEPEND needs DOCS_AUTODOC which needs the extension
+ sed -i -e "/^extensions/s/$/ 'sphinx.ext.autodoc',/" docs/source/conf.py || die
+}
+src_configure() {
+ local emesonargs=(
+ $(meson_use test build_tests)
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+ docs_compile
+}