summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-03 05:31:06 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-03 05:42:41 +0200
commit232fd03b5ef344e0795bf4467ee3f3943c3a3996 (patch)
tree3cf553f263afbc35e831553d738a3a061e612e8a
parentapp-office/kmymoney: mark as LTO-unsafe (diff)
downloadgentoo-232fd03b5ef344e0795bf4467ee3f3943c3a3996.tar.gz
gentoo-232fd03b5ef344e0795bf4467ee3f3943c3a3996.tar.bz2
gentoo-232fd03b5ef344e0795bf4467ee3f3943c3a3996.zip
dev-python/rapidfuzz: Bump to 3.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rapidfuzz/Manifest1
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-3.9.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index 5329d07dcabb..da80c5258bad 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1 +1,2 @@
DIST rapidfuzz-3.8.1.tar.gz 1592462 BLAKE2B 79062be1bdd2e5aa1c364f2426a8b3cb4fc03e44b7548e475abd60827821414ce4ebcbe90377c0d19eb2c8c741e2e171c73e4672fd8126bf99856ea095e9b85b SHA512 fbebdf804220841257075af51186cde5cf8b0ea71bc4ce208bc64853fd1b1aebf97bfb86d1db058c3fb72a60268e5297fe3691b042d52263c66f8da6ae37f90a
+DIST rapidfuzz-3.9.0.tar.gz 1591028 BLAKE2B 84b8e4572a596c291d6579cfdffd0d624e00ca1f93a38337ba6ad543d346fea0b9a636cd3814724073588b3cd2e61dea9b8c0527b1630f8f06ea6593537bbde6 SHA512 bfd0d399dc75c6654d5e66522a057298d3914f8b74955e873034b314926127971f1bf4ddca0c2c92e81ba5bae79caf249303b169805d48ef3d6c64fb706c9547
diff --git a/dev-python/rapidfuzz/rapidfuzz-3.9.0.ebuild b/dev-python/rapidfuzz/rapidfuzz-3.9.0.ebuild
new file mode 100644
index 000000000000..9bf96f9f14b7
--- /dev/null
+++ b/dev-python/rapidfuzz/rapidfuzz-3.9.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
+HOMEPAGE="
+ https://github.com/rapidfuzz/RapidFuzz/
+ https://pypi.org/project/rapidfuzz/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# all these are header-only libraries
+DEPEND="
+ >=dev-cpp/taskflow-3.0.0
+ >=dev-cpp/rapidfuzz-cpp-3.0.4
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/rapidfuzz-capi[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+ # remove bundled libraries
+ rm -r extern || die
+ # force recythonization
+ find src -name '*.cxx' -delete || die
+
+ distutils-r1_src_prepare
+
+ export RAPIDFUZZ_BUILD_EXTENSION=1
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # scikit-build is broken and reuses the same build
+ # https://github.com/scikit-build/scikit-build/issues/633
+ rm -r _skbuild || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}