summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-25 16:21:33 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-12-25 16:23:42 -0800
commit234d2a59658960eaf2382bec7e1b69b69a70ac41 (patch)
tree1f4e062382e5c6b7ea446d536e9c9cba3987eb01
parentdev-python/cached-property: keyword on ~ppc64 (diff)
downloadgentoo-234d2a59658960eaf2382bec7e1b69b69a70ac41.tar.gz
gentoo-234d2a59658960eaf2382bec7e1b69b69a70ac41.tar.bz2
gentoo-234d2a59658960eaf2382bec7e1b69b69a70ac41.zip
dev-python/fqdn: bump to 1.2.0
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-python/fqdn/Manifest1
-rw-r--r--dev-python/fqdn/fqdn-1.2.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/fqdn/Manifest b/dev-python/fqdn/Manifest
index ff53781b25eb..69b25a3a75f2 100644
--- a/dev-python/fqdn/Manifest
+++ b/dev-python/fqdn/Manifest
@@ -1 +1,2 @@
DIST fqdn-1.1.1.tar.gz 12056 BLAKE2B 8f78e16b73239ec7dbd2f1565026459c08b80245999b4bd93fe7119f45f604c84ae9d60cbb42aec147d5096bb1a6b1898a2d884db244e1ad507ed516aa3591b3 SHA512 46487bcdf2639b84023f710c323b33b8bdb9a3a3d6e7f22c1e9b759940193f9473d3bd639678ab377741ce84c180bc18eb7e65060fdd59189dacadcb50df317b
+DIST fqdn-1.2.0.tar.gz 12275 BLAKE2B 0bc862863ee3b196ea08a1f4f50f98dca88e8b81f37d2cb97bd3fd74ef9844157ea7a9f38707047fad17b95fb95c2f0e7ace8ad2c2310171cba6ff43471ae63d SHA512 ddfcfd82860d597075fd2d989d4bb1cd8c1dc79b711da432732bf786032e78b9356e04851a491c5299b336dcde173a66ddae0e23aea59b67c758d997554b494e
diff --git a/dev-python/fqdn/fqdn-1.2.0.ebuild b/dev-python/fqdn/fqdn-1.2.0.ebuild
new file mode 100644
index 000000000000..0a1223b3eebf
--- /dev/null
+++ b/dev-python/fqdn/fqdn-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC-compliant FQDN validation and manipulation for Python"
+HOMEPAGE="https://github.com/guyhughes/fqdn"
+SRC_URI="https://github.com/guyhughes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/cached-property[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest