summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-20 06:52:35 +0000
committerSam James <sam@gentoo.org>2020-10-20 06:53:45 +0000
commit23501d1efa116037dedb3ab3f5e184bae0c9c6cf (patch)
tree9496113e0f124633b58ba1d9a1a13e6ea868e6af
parentmedia-sound/alsa-utils: stable 1.2.3 for hppa (diff)
downloadgentoo-23501d1efa116037dedb3ab3f5e184bae0c9c6cf.tar.gz
gentoo-23501d1efa116037dedb3ab3f5e184bae0c9c6cf.tar.bz2
gentoo-23501d1efa116037dedb3ab3f5e184bae0c9c6cf.zip
net-misc/unison: install docs for unison-2.48.15_p4
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/unison/unison-2.48.15_p4-r2.ebuild (renamed from net-misc/unison/unison-2.48.15_p4-r1.ebuild)21
1 files changed, 12 insertions, 9 deletions
diff --git a/net-misc/unison/unison-2.48.15_p4-r1.ebuild b/net-misc/unison/unison-2.48.15_p4-r2.ebuild
index d8102533b702..17bbdc2c4a4b 100644
--- a/net-misc/unison/unison-2.48.15_p4-r1.ebuild
+++ b/net-misc/unison/unison-2.48.15_p4-r2.ebuild
@@ -5,17 +5,20 @@ EAPI=7
inherit desktop xdg-utils
+# Use the docs for the last 'normal' release
+DOC_P="${PN}-2.48.4"
DESCRIPTION="Two-way cross-platform file synchronizer"
HOMEPAGE="https://www.seas.upenn.edu/~bcpierce/unison/"
SRC_URI="https://github.com/bcpierce00/unison/archive/v${PV/_p/v}.tar.gz -> ${P/_p/v}.tar.gz"
# No manual.pdf or manual.html available for this version
-# doc? ( https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
-# https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
+SRC_URI+=" doc? ( https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${DOC_VER}/${DOC_P}-manual.pdf
+ https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${DOC_VER}/${DOC_P}-manual.html )
+"
LICENSE="GPL-2"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
-IUSE="debug gtk +ocamlopt threads"
+IUSE="debug doc gtk +ocamlopt threads"
# Upstream, for this version, has explicitly disabled test with marker
# "Skipping some tests -- remove me!". Given the potentially destructive nature
@@ -77,14 +80,14 @@ src_install() {
if use gtk; then
newicon -s scalable ../icons/U.svg ${PN}-${SLOT}.svg
- make_desktop_entry unison-${SLOT} "${PN} (${SLOT})" "${EPREFIX}/usr/share/${PN}/${PN}-${SLOT}.svg"
+ make_desktop_entry unison-${SLOT} "${PN} (${SLOT})" "${EPREFIX}/usr/share/icons/hicolor/scalable/apps/${PN}-${SLOT}.svg"
+ fi
+
+ if use doc; then
+ DOCS+=( "${DISTDIR}/${DOC_P}-manual.pdf" )
+ HTML_DOCS=( "${DISTDIR}/${DOC_P}-manual.html" )
fi
-# No manual.pdf or manual.html available for this version
-# if use doc; then
-# DOCS+=( "${DISTDIR}/${P}-manual.pdf" )
-# HTML_DOCS=( "${DISTDIR}/${P}-manual.html" )
-# fi
einstalldocs
}