summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-10-30 00:35:29 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-31 09:22:25 +0100
commit239d0c8bbfff2f258149aed55337c7bb0cf38d71 (patch)
treeaeac79625d59c924119c5218f50e409c8c731f3e
parentsci-physics/meep: Version bump to 1.3, EAPI bump 4 -> 6 (diff)
downloadgentoo-239d0c8b.tar.gz
gentoo-239d0c8b.tar.bz2
gentoo-239d0c8b.zip
sci-physics/yoda: Version bump to 1.6.5 and EAPI bump 5 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2698 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-physics/yoda/Manifest1
-rw-r--r--sci-physics/yoda/yoda-1.6.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/sci-physics/yoda/Manifest b/sci-physics/yoda/Manifest
index 4e6f6171a00d..47f9f9732d4d 100644
--- a/sci-physics/yoda/Manifest
+++ b/sci-physics/yoda/Manifest
@@ -1 +1,2 @@
DIST YODA-1.4.0.tar.bz2 809432 SHA256 e76a129f7c2b72b53525fe0b712606eeeab0dc145daa070ebf0728f0384eaf48 SHA512 f1873888f3d2c28d42ac54fa9f3fa4a98e648a638ebceffce0a2f742c5fb6647fabd0de49c00407741e937600fc8a12d33ca26b8b9cd9b81c28a4d2e11f2bd3a WHIRLPOOL 6c8e0176b729d951351b3b9d574c91add5d6302aa76417241e560f3f3bbf38f4b60f41713d89a03a62b1c4ad3a98bd5342fd05901671e6aedf0c2c11dc36b024
+DIST YODA-1.6.5.tar.bz2 818613 SHA256 1477fe754cfe2e4e06aa363a773accf18aab960a8b899968b77834368cac14c5 SHA512 bead0a3ada233c1fbafe66d25e65262c20d9a9dfa6265440320a0fc782e91b3ac6581698e2015d86f2b58dc305dedbc48ed648ff03ec9f6abc11a7fb27938b1a WHIRLPOOL b6b88832b89357dbf0309641f9e4180f0c0fabf917ec7f36bafe75b811b849f0cf1cf24877b468b50d340f7a1ae1575d07fc63e9ec810a318dda7adb9b9aeed7
diff --git a/sci-physics/yoda/yoda-1.6.5.ebuild b/sci-physics/yoda/yoda-1.6.5.ebuild
new file mode 100644
index 000000000000..ee66c0a1e70d
--- /dev/null
+++ b/sci-physics/yoda/yoda-1.6.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 python-single-r1
+
+DESCRIPTION="Yet more Objects for (High Energy Physics) Data Analysis"
+HOMEPAGE="http://yoda.hepforge.org/"
+
+SRC_URI="http://www.hepforge.org/archive/${PN}/${P^^}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="python root static-libs"
+
+RDEPEND="
+ dev-libs/boost:=
+ python? ( ${PYTHON_DEPS} )
+ root? ( sci-physics/root:=[python=,${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${P^^}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_enable python pyext) \
+ $(use_enable root) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ newbashcomp "${ED%/}"/usr/share/YODA/yoda-completion ${PN}
+ rm "${ED%/}"/usr/share/YODA/yoda-completion || die
+}