summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-05-15 09:47:31 -0700
committerMatt Turner <mattst88@gentoo.org>2021-05-15 09:54:51 -0700
commit23b0dbba660fe72abee54d62383c532d18e092bd (patch)
tree925770b220ada389548c1a52ed28b3f6a11f37db
parentgnome-base/gnome-shell: Version bump to 40.1 (diff)
downloadgentoo-23b0dbba660fe72abee54d62383c532d18e092bd.tar.gz
gentoo-23b0dbba660fe72abee54d62383c532d18e092bd.tar.bz2
gentoo-23b0dbba660fe72abee54d62383c532d18e092bd.zip
gnome-extra/gnome-shell-extensions: Version bump to 40.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extensions/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions/Manifest b/gnome-extra/gnome-shell-extensions/Manifest
index 69c049a644b1..172dfe168c23 100644
--- a/gnome-extra/gnome-shell-extensions/Manifest
+++ b/gnome-extra/gnome-shell-extensions/Manifest
@@ -1,2 +1,3 @@
DIST gnome-shell-extensions-3.38.2.tar.xz 209904 BLAKE2B b9a32e9c20046cb480dae3ed27791958799f534dc19026631290d2d0bcfac04955e77b2779f9a18e32d7ee56f837e8e17167bd40b575ff531b8cc328a9c0cc35 SHA512 5106946c10ea34b339ef413d5cf6bc3e1cd7f54f73b0ca773ae4076c1280e2b235327c9209e8269c5aca787035b489f73a76c7163380f191cb246c8591bc838c
DIST gnome-shell-extensions-40.0.tar.xz 217772 BLAKE2B de2f88dd37a0b9bbbbcbd7373e18b8589d4a35a9497404a4e46a0e4aad7058890c6b596edd553cbb68dd6ab9db6bc81d8ae5457be02a4af2b2cc4b8fd2d8691d SHA512 9f4b4a5d91201c11246c2df880b568d69264ad875bfdc2b69d217aca0e4354223aeed51007396a339fb9a693eab9849362641fa9a064a5efdda7fad5b886af85
+DIST gnome-shell-extensions-40.1.tar.xz 218084 BLAKE2B 0f54dc53ce279af424658d540961bda698c4d6c2968bf778e626a91c7da47b8f56bd4b1dd874956dce9fbb0d1719bd64b8cf8883788d625049aa14dcc02ff313 SHA512 e537312c0790b6e54b3eebb0df189f65f093e81ec7cf1cde886df747188765775fc4616e98bff0157b543bac26c51a5c7006f1505f4554fea00972f790e781f1
diff --git a/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.1.ebuild b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.1.ebuild
new file mode 100644
index 000000000000..3c33ad2de500
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions/gnome-shell-extensions-40.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org readme.gentoo-r1 meson xdg
+
+DESCRIPTION="JavaScript extensions for GNOME Shell"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.26:2
+ >=gnome-base/libgtop-2.28.3[introspection]
+ >=app-eselect/eselect-gnome-shell-extensions-20111211
+"
+RDEPEND="${DEPEND}
+ >=dev-libs/gjs-1.29
+ dev-libs/gobject-introspection:=
+ dev-libs/atk[introspection]
+ gnome-base/gnome-menus:3[introspection]
+ =gnome-base/gnome-shell-$(ver_cut 1-2)*
+ media-libs/clutter:1.0[introspection]
+ net-libs/telepathy-glib[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme
+ >=x11-wm/mutter-3.32[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Installed extensions installed are initially disabled by default.
+To change the system default and enable some extensions, you can use
+# eselect gnome-shell-extensions
+
+Alternatively, to enable/disable extensions on a per-user basis,
+you can use the https://extensions.gnome.org/ web interface, the
+gnome-extra/gnome-tweaks GUI, or modify the org.gnome.shell
+enabled-extensions gsettings key from the command line or a script."
+
+src_configure() {
+ meson_src_configure \
+ -Dextension_set=all \
+ -Dclassic_mode=true
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+
+ readme.gentoo_print_elog
+}