summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-02-11 20:33:12 +0100
committerManuel Rüger <mrueg@gentoo.org>2019-02-11 20:33:12 +0100
commit23d4df7642c4525cd6e2c0aa053c5c303dde1082 (patch)
tree44460c57896824b62eccd00114260471bf64069e
parentapp-emulation/runc: Stabilize on amd64 (diff)
downloadgentoo-23d4df76.tar.gz
gentoo-23d4df76.tar.bz2
gentoo-23d4df76.zip
app-emulation/runc: Remove old
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
-rw-r--r--app-emulation/runc/runc-1.0.0_rc5_p20180509.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc5_p20180509.ebuild b/app-emulation/runc/runc-1.0.0_rc5_p20180509.ebuild
deleted file mode 100644
index eb9cce7cf94b..000000000000
--- a/app-emulation/runc/runc-1.0.0_rc5_p20180509.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/opencontainers/${PN}"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-build golang-vcs
-else
- MY_PV="${PV/_/-}"
- EGIT_COMMIT="v${MY_PV}"
- RUNC_COMMIT="69663f0bd4b60df09991c08812a60108003fa340" # Change this when you update the ebuild
- SRC_URI="https://${EGO_PN}/archive/${RUNC_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64"
- inherit golang-build golang-vcs-snapshot
-fi
-
-DESCRIPTION="runc container cli tools"
-HOMEPAGE="http://runc.io"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+ambient apparmor hardened +seccomp"
-
-RDEPEND="
- apparmor? ( sys-libs/libapparmor )
- seccomp? ( sys-libs/libseccomp )
- !app-emulation/docker-runc
-"
-
-src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
-
- # build up optional flags
- local options=(
- $(usex ambient 'ambient')
- $(usex apparmor 'apparmor')
- $(usex seccomp 'seccomp')
- )
-
- GOPATH="${S}"\
- emake BUILDTAGS="${options[*]}" \
- COMMIT="${RUNC_COMMIT}" -C src/${EGO_PN}
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin runc
- dodoc README.md PRINCIPLES.md
- popd || die
-}