summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-14 09:00:38 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-14 09:10:16 +0100
commit23e5cf05ba6c20a2f64b0c9bb4a83f7ebd66a25b (patch)
tree8192d8e252c6e49911693f0b94ecef05757f7000
parentdev-ruby/tdiff: add ruby30 (diff)
downloadgentoo-23e5cf05ba6c20a2f64b0c9bb4a83f7ebd66a25b.tar.gz
gentoo-23e5cf05ba6c20a2f64b0c9bb4a83f7ebd66a25b.tar.bz2
gentoo-23e5cf05ba6c20a2f64b0c9bb4a83f7ebd66a25b.zip
dev-ruby/maruku: EAPI 8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/maruku/maruku-0.7.3-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/maruku/maruku-0.7.3-r1.ebuild b/dev-ruby/maruku/maruku-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..1b6182e61b80
--- /dev/null
+++ b/dev-ruby/maruku/maruku-0.7.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="docs/div_syntax.md docs/entity_test.md
+ docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
+ docs/proposal.md"
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Markdown-superset interpreter written in Ruby"
+HOMEPAGE="https://github.com/bhollis/maruku"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="highlight test"
+
+ruby_add_bdepend "test? ( dev-ruby/nokogiri-diff dev-ruby/syntax )"
+ruby_add_rdepend "highlight? ( dev-ruby/syntax )"
+
+DEPEND+=" test? ( app-text/blahtexml )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' spec/spec_helper.rb || die
+}
+
+pkg_postinst() {
+ elog
+ elog "You need to emerge app-text/texlive and dev-texlive/texlive-latexextra if"
+ elog "you want to use --pdf with Maruku. You may also want to emerge"
+ elog "dev-texlive/texlive-latexrecommended to enable LaTeX syntax highlighting."
+ elog
+}