summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-07-24 09:54:05 +0200
committerDavid Seifert <soap@gentoo.org>2017-07-30 11:34:09 +0200
commit23ec596abdbe08202da0c2e16ad385c0c43f79a2 (patch)
tree293eb2330fb68d39e3dac6293f604c30d9a7364e
parentdev-python/testpath: Version bump to 0.3.1 (diff)
downloadgentoo-23ec596a.tar.gz
gentoo-23ec596a.tar.bz2
gentoo-23ec596a.zip
dev-python/smmap2: Version bump to 2.0.3
Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5197
-rw-r--r--dev-python/smmap2/Manifest1
-rw-r--r--dev-python/smmap2/smmap2-2.0.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/smmap2/Manifest b/dev-python/smmap2/Manifest
index 27e0f964b8a6..68fb163e524d 100644
--- a/dev-python/smmap2/Manifest
+++ b/dev-python/smmap2/Manifest
@@ -1 +1,2 @@
DIST smmap2-2.0.1.tar.gz 21948 SHA256 5c9fd3ac4a30b85d041a8bd3779e16aa704a161991e74b9a46692bc368e68752 SHA512 7c8d27c06befdabf65049e5e0bac5beb07c19ff398a343d953120b9cb1c9ed203232012f4b12180af20fa0dde8feb0d6e8af3e389932407688bcc345548f2501 WHIRLPOOL 973d82e6cd679a82189c617469cb4d749f12d56f8aa0d0cdac9177fb09ae71c3986200730a1b320479a4ee87e9796602f17aadf5b2e12f29d0e950ec9ebcbbbf
+DIST smmap2-2.0.3.tar.gz 23049 SHA256 c7530db63f15f09f8251094b22091298e82bf6c699a6b8344aaaef3f2e1276c3 SHA512 f5623247fbdb6b0e94bbfe7104ffd84ee4563a0c32781256d92d46fd23e05280d7a0e3952a573b6834e253e9b68175784babc36d91ab61edf6d0d072830e1fde WHIRLPOOL ac3c7d934130ef71e54c03fd328c54a598d041eb0e74abae80832e2bb0b7a7dbc9f466f348d760cf73df19e491e959fe5b81f4e8eac41c93ebdfc91133c702f2
diff --git a/dev-python/smmap2/smmap2-2.0.3.ebuild b/dev-python/smmap2/smmap2-2.0.3.ebuild
new file mode 100644
index 000000000000..27eb3c7208c4
--- /dev/null
+++ b/dev-python/smmap2/smmap2-2.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.python.org/pypi/smmap2
+ https://github.com/gitpython-developers/smmap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ !dev-python/smmap[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests -v || die "tests failed under ${EPYTHON}"
+}