summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 09:52:40 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 12:01:05 +0100
commit23f2d57d8eeae1da9e2a17b3b717cbe2b01ca3b7 (patch)
treedc05ab4835c55973adf3d12e19036a082c50812b
parentdev-python/nose: Enable py3.8 (diff)
downloadgentoo-23f2d57d.tar.gz
gentoo-23f2d57d.tar.bz2
gentoo-23f2d57d.zip
dev-python/zope-event: Enable py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/zope-event/zope-event-4.3.0.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-python/zope-event/zope-event-4.3.0.ebuild b/dev-python/zope-event/zope-event-4.3.0.ebuild
index 69deae1141c6..9304525d1aa7 100644
--- a/dev-python/zope-event/zope-event-4.3.0.ebuild
+++ b/dev-python/zope-event/zope-event-4.3.0.ebuild
@@ -2,30 +2,26 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
inherit distutils-r1
-MY_PN=zope.event
+MY_PN=zope.event
MY_P=${MY_PN}-${PV}
+
DESCRIPTION="Event publishing / dispatch, used by Zope Component Architecture"
HOMEPAGE="https://github.com/zopefoundation/zope.event http://docs.zope.org/zope.event/"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="ZPL"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-S=${WORKDIR}/${MY_P}
-
-python_test() {
- nosetests || die
-}
+distutils_enable_tests nose
python_install_all() {
distutils-r1_python_install_all