summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-07 23:56:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-08 00:56:50 +0100
commit2400d07c2adbf5157abc7dde16892c4597d350e8 (patch)
treea606a3461c6f5f940bde7622b0c16768fd459417
parentdev-python/python-poppler-qt5: python3_9 (diff)
downloadgentoo-2400d07c.tar.gz
gentoo-2400d07c.tar.bz2
gentoo-2400d07c.zip
dev-python/python-poppler-qt5: Use qmake-utils
Closes: https://bugs.gentoo.org/764065 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
index 73a70b8349a0..e737b69a306c 100644
--- a/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
+++ b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit distutils-r1
+inherit distutils-r1 qmake-utils
DESCRIPTION="Python binding for libpoppler-qt5"
HOMEPAGE="https://github.com/frescobaldi/python-poppler-qt5"
@@ -21,3 +21,12 @@ RDEPEND="
>=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+
+python_compile() {
+ distutils-r1_python_compile build_ext --qmake-bin=$(qt5_get_bindir)/qmake
+}
+
+python_install() {
+ export PATH=$(qt5_get_bindir):$PATH
+ distutils-r1_python_install
+}