summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-03-21 16:52:24 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-21 16:52:24 +0100
commit2406c1dbc6ddb806db03bfee769d6a8617b6a760 (patch)
treedbd72466a0ebb3521ca312781889fc8a32021a26
parentgui-libs/eglexternalplatform: new package 1.1 (diff)
downloadgentoo-2406c1dbc6ddb806db03bfee769d6a8617b6a760.tar.gz
gentoo-2406c1dbc6ddb806db03bfee769d6a8617b6a760.tar.bz2
gentoo-2406c1dbc6ddb806db03bfee769d6a8617b6a760.zip
gui-libs/egl-wayland: new package 1.1.6
Split off from nvidia-drivers[wayland] which formerly only provided runtime files (no pkgconfig). Uses its own versioning and doesn't seem to need to match drivers, so it makes more sense as its own package. Package is needed to provide EGLStream (nvidia's workaround to get acceleration on wayland) support notably in x11-wm/mutter (wants the pkg-config file) and some other wayland compositors. Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19812 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--gui-libs/egl-wayland/Manifest1
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild41
-rw-r--r--gui-libs/egl-wayland/files/10_nvidia_wayland.json6
-rw-r--r--gui-libs/egl-wayland/metadata.xml15
4 files changed, 63 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
new file mode 100644
index 000000000000..8789cb0974d5
--- /dev/null
+++ b/gui-libs/egl-wayland/Manifest
@@ -0,0 +1 @@
+DIST egl-wayland-1.1.6.tar.gz 48674 BLAKE2B 66f58d4b841ebaaec6c0711e0dae0b3c774a7b0206f9cfd4d9e94a2c05688d563fddbbf9a60247980df00c3c493147e292bc536e2eb56de962f3b34c6215e026 SHA512 81fd3be3f49ad012efd31189d85666e869653f1f4004de4103f4ad13b7fda036cef432d1e30e33664ae423092dc1b86cfd2773d6542bb09d7a74720ba14e0fa4
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
new file mode 100644
index 000000000000..6d38529baad1
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="EGLStream-based Wayland external platform (for NVIDIA)"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland"
+SRC_URI="https://github.com/NVIDIA/egl-wayland/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/wayland
+ !x11-drivers/nvidia-drivers[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ gui-libs/eglexternalplatform
+ media-libs/libglvnd"
+BDEPEND="dev-util/wayland-scanner"
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To use EGLStream with x11-drivers/nvidia-drivers, it is necessary to"
+ elog "load the nvidia-drm module with experimental nvidia-drm.modeset=1."
+ elog
+ elog "Can be accomplished by:"
+ elog " echo 'options nvidia-drm modeset=1' > ${EROOT}/etc/modprobe.d/nvidia-drm.conf"
+ elog "...then reloading the module."
+ fi
+}
diff --git a/gui-libs/egl-wayland/files/10_nvidia_wayland.json b/gui-libs/egl-wayland/files/10_nvidia_wayland.json
new file mode 100644
index 000000000000..c08a64112af8
--- /dev/null
+++ b/gui-libs/egl-wayland/files/10_nvidia_wayland.json
@@ -0,0 +1,6 @@
+{
+ "file_format_version" : "1.0.0",
+ "ICD" : {
+ "library_path" : "libnvidia-egl-wayland.so.1"
+ }
+}
diff --git a/gui-libs/egl-wayland/metadata.xml b/gui-libs/egl-wayland/metadata.xml
new file mode 100644
index 000000000000..cb6ef54fb36c
--- /dev/null
+++ b/gui-libs/egl-wayland/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>sudinave@gmail.com</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">NVIDIA/egl-wayland</remote-id>
+ </upstream>
+</pkgmetadata>