summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 06:33:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 07:34:46 +0200
commit240ef177e1542f04d6053f802d28c1fd1cc8dedb (patch)
tree71cd48aa1d44f8c7c0d133b09058aa96e0926247
parentapp-crypt/pinentry: Stabilize 1.2.1-r3 ppc, #906793 (diff)
downloadgentoo-240ef177.tar.gz
gentoo-240ef177.tar.bz2
gentoo-240ef177.zip
dev-python/botocore: Bump to 1.29.137
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.137.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index b7736b7f0802..85ba47968aa6 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -9,3 +9,4 @@ DIST botocore-1.29.133.gh.tar.gz 11484789 BLAKE2B ce1acc51ffada796e594090e7b4d73
DIST botocore-1.29.134.gh.tar.gz 11487191 BLAKE2B a50ff2681ebd56a55138b29be3177dd814ec4b37e4dbeb2144013c9b812de0db0593cc011347024d2c441d4d513180f0b98b26f89a17747b2a4a06a2c71dd9b4 SHA512 4358d3a4baf1f255f1d0d42fa331bad29d8e8d700156789723837bc60fc290d145a763ddfdadf6d78ee216de68332bed5b3b158858807718fbff35b853387c91
DIST botocore-1.29.135.gh.tar.gz 11491287 BLAKE2B 722ba9b0a679b947e0d59a761d7711b44929005764f223cff23455ca43ae54f4b8c7ae0b055afb42e0a95673ecc4303c41ab98144c05abeaa5bd33bb02d4f8ae SHA512 09ebb3b853b6ef8b275b92716cd2ecce780f58c9a26aece2bbc5ffc30e9dd2e3746758b7a9de6eff4b81e959b8c57bbdbc71f64b21ceb73d024b76cec456b12d
DIST botocore-1.29.136.gh.tar.gz 11494292 BLAKE2B 99186af221bcb9d5d45efaa467ce71bae87e995e958a24d08e540ae5377fa1b6a2ab44be24e05dab53182cbee6fa80435090917ec4e983d668dacc48302cdcb5 SHA512 00da837d157efb32a8cc1dcdd9b36d257955863c83bcad25609623bf74e13de50cdcee686da80845045202014c8402738bd0def0bb629a95780ac94f1ad64510
+DIST botocore-1.29.137.gh.tar.gz 11508178 BLAKE2B 2f74fd2f3923672a4fcd501f1c5ba48cd09965ea0f70689bd6559a4c4a6fe8921f783ef86f28ac57893c8b1366d8fca2fc79f0216747e04142ed33880f07fe39 SHA512 b800a1b73170b5fcbbf1b17477bb8f04b19f5f250a68bbb3b993b0e058d8df870eddf932f79d94eaa3255b976ce136adbdd5b359757cd79f2cfe2a16b3cfa2f4
diff --git a/dev-python/botocore/botocore-1.29.137.ebuild b/dev-python/botocore/botocore-1.29.137.ebuild
new file mode 100644
index 000000000000..3ced99abe4ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.137.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ # urllib3-2 compatibility, mock relies on implementation details
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_no_response_from_server
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_returned
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_continue_sends_307
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_expect_100_sends_connection_header
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_handles_expect_100_with_different_reason_phrase
+ tests/unit/test_awsrequest.py::TestAWSHTTPConnection::test_state_reset_on_connection_close
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}